powered by Jive Software

Disable file transfer on JIve/Wildfire - pls hlp

Can I reject the file transfers feature on Jive or Wildfire? I using Jive ver 2.2.1 running on RedHat 9 and Wildfire ver 2.6.2 running on Windows 2K Prof. On Wildfire there is options for File Transfer but nothing happens. Users still can exchange file each other.

Please step by step solution.

thx

The problem is that some clients are point to point in regards to file transfer. Yes, you can configure a client to go through Wildfire to transfer, but this is only a preference setting, and users can still go back to reset this. My suggestion is either force the use of a client that only transfers through the server, or shut off port 7777, which is the default transfer port.

Jeff

Hi,

the clients use the server to exchange the initial file transfer packets. So you could write a Wifi plugin / PacketInterceptor which rejects these packets - this would cause some trouble for the clients and they would not be able to initiate a normal file transfer.

Spark then tries to send the file as within special IM message, also there you could use a plugin to reject the packets.

The Socks proxy was introduced with Wifi 2.x and you can disable it in the admin GUI.

LG

I will be implementing this feature in Wildfire in the next few weeks:

JM-675

Alex

and how I installed PacketInterceptor to Server program?

thx

Hi,

Alex is writing the code, if you did never develop a Wifi plugin you may find it very difficult to start. If you want to start working on this issue please send him a private message.

LG

Thank God…

Alex, thx for implement that feature on Wildfire. I hope that plugins can work fine on Jive 2.2.1 too. hihihihi

LG, thx for answer my questions.

-Ms. Pinkan, Jakarta