powered by Jive Software

Disable send last item published entirely from pubsub?

Hi, I think that I have sent the correct IQ stanza to disable the pubsub service from sending the last published item whenever a subscriber enters his or her feed. It is listed below.

The problem is, I’m still getting that last item sent back upon entering a feed for the first time. It seems after the first time, the message is no longer being sent. Did I do something wrong here or is there another way to disable sending back delayed messages?

SEND:

http://jabber.org/protocol/pubsub#node_config

10000

1

open

never

subscribers

Thanks!

Apparantly there is some confusion around send_last_published_item (doc vs actual implementation). I had the same problem and solved it by setting pubsub#send_item_subscribe to 0.

Cheers,

Mark