powered by Jive Software

Documentation incorrect regarding admin login after setup

On a fresh install of Openfire 3.8.2, the documentation implies that the admin user’s email address and password will be what you use to log in during the final step when you are redirected to the admin control panel.

Upon entering these credentials, I get an authentication error. Restarting Openfire as suggested in many similar error reports does not make any difference.

In order to log in as the admin user, I had to enter admin / admin as the username and password.

Once in, I am able to change the admin password, but not the admin user name, as per the final comment here: http://community.igniterealtime.org/message/185628#185628

This is a fresh install using the RPM on Fedora 20.


Actually, documentation doesn’t imply this, though it is a common confusion that email should be used for a login.

admin/admin should only work if this step is skiped (no new password provided) or probably something is wrong with the permissions and setup is not able to save the new password. Are you using the embedded database? It is in the same folder where Openfire is installed and the user running the setup has to have full permissions on all Openfire/ folders.

Built-in admin username can’t be changed. You say you are able to change the passowrd once you login with admin/admin. Are you able then to login with admin/newpassword? What if you restart the Openfire server?

I’m talking about this screen, which insinuates that you can set the administrator password on this screen. Instead, it seems that the new password / confirm password inserted here is ignored.

Though in writing this, I realize you are probably expected to insert “admin” as the password in the current password field, and if you don’t the update password mechanism doesn’t work.

All in all, quite a confusing experience for the first time user.

A) why require a default ‘admin’ password to set the new password in a fresh install. Can’t we just set the new password?

B) if it’s a common confusion that you’d use the email (I would be this is because the screen below suggests that you’ll be using the admin password in the sign in screen, that’s a very common sign in pattern, so it’s normal to expect that’s what you’re setting up in this screen), it may be useful to users to either not ask for the password in this screen, or make it extremely clear in the following page that you need to use “admin” as the username in the login screen (or why not just pre-populate that field for us, so that it’s crystal clear what we need to do?).

I only harp on about this because it caused me to spend 10 minutes reinstalling the system, and searching around until I found a random forum post that explained it.

That’s very close to a “this doesn’t work so I’m giving up and looking for another solution” experience.

Unfortunate, because you’ve got quite a nice software now that I’m using it, so it’s a pity if people give up just because the install process isn’t clear.


Btw, i’m not the one who wrote this software Actually, original developers are not here anymore. We are just a few guys trying to answer question on the forums and a few occasional patchers.

The screen you see is only shown when you run a setup over the already setup database. The fresh install should show a screen i uploaded (no Current password field). So, if you say it is a first setup (or you just launched the setup again on an already setup server to make a screenshot?) then it might be an issue with the permissions on /openfire/conf/openfire.xml file.

I don’t know what was the idea behind the “If this is a new installation, the current password will be ‘admin’.” line. I can’t think of a real situation when this could occur. Unless you started to setup the server, abruptly stopped this and then start again, but still want to use the same database and not start with the fresh one…

I have emphasized the parts that say that the username is admin. And that it doesn’t say login or username near the Admin Email Address field. I just want to point, that the text here is not misleading or implying something wrong. Actually, if i recall correctly i have filed a ticket to add this “(username of admin)” not so long ago, to make it more clear. But it looks like we still have to deal with the perception, that if email address is present in the form and there is no username input field, then you should probably use that email as login

Well, i don’t like putting the email alone on a separate screen (and it would involve more programming, though it is only jsp pages). So maybe something like “This installation of Openfire is now complete. To continue press the button below and login using admin as a username and the password you have provided:” at the last page would be sufficient to clear the confusion?