Does openfire support file transfers? vcards?

I’m running Openfire 3.7.0beta with Spark 2.6.0rc1

I’ve noticed that file transfers between two Spark clients don’t work

I’ve also noticed that if I add details to my profile in Spark and try to save, it says that the server doesn’t support vcards

It seems strange to me that Spark has features that Openfire supports. Is there something I have to enable for this to work?

I’m able to do file transfers between RC1 versions of Spark. Usually this is a direct peer-2-peer transfer without server being involved.

As about vcards. Maybe you have Client Control plugin installed on the server? You can block vcard updates in Spark client with this plugin.

Also, check the system propery “vcard.enabled”. Maybe it is set to false.

I do not have Client Control installed. Where does the vcard.enabled property reside? Some kind of configuration file?

As for file transfers: I’ve only tried so far between two 2.6.0RC1 clients, but one was running on Windows and one was running on Mac. The Mac client never even saw the file transfer request. I’ll try testing this more thoroughly on Monday.

I wonder if this article is still valid:

Admin Console > Server > System Properties. There you should find vcard.enabled property, or you can create it yourself.

This could be a Mac issue. Or just some other issue with file transfers. This area of IM (not just Spark) is very tricky. All those networks issues that a file transfer must overcome is hard to investigate and solve. Speaking about Spark file transfer never worked flawlessly, especially now that the code was rewritten almost entirely to get rod if commercial parts and libraries. There are some issues with transfer speeds. It is usually very slow, though i’m testing with 2 PCs connected with a cable. And i can’t figure out what’s happening. Also this is probably too complex for our current volunteers developers to investigate and fix.

This document is mostly valid in theory. In the case of Spark’s UI it is mostly valid, though there are i think some glitches in that part. As about transfers themselves i can’t say for sure. Sometimes transfers just don’t work, even in the same local network. In-Band transfers should theoretically always work (maybe slower), but maybe Spark is not always switching to that mode if p2p fails.

You can check Server > Server Settings > File Transfer Settings and enable proxy in there, though maybe it is enabled by default. Maybe it will help.

ok, I see the file transfer proxy server is set to use a particular port. I’m guessing I need to open that port on the server firewall for it to work …

there is no vcard.enabled property in Server Properties. the closest is provider.vcard.className. so I guess I will have to create it