powered by Jive Software

Eclipse + Openfire 3.9 onwards not importing correctly

Have some time this weekend to spend on Openfire duties but struggling to get Eclipse to see the new ‘Openfire’ git repo I’ve just checked out.

Following the instructions below as I’ve done dozens of times before but Eclipse completely scrambles the repo src paths. No issues checking out the SVN path. Any suggestions?

http://community.igniterealtime.org/docs/DOC-1020

Just to add it affects Git and SVN trunk (3.9). Checking out 3.8.2 SVN tag imports just fine.

Here’s the 3.8.2 project, Eclipse imported it perfectly:

Here’s the 3.9.X project, Eclipse screwed it up:

Repeated this process about 3-4 times now and it has the same result everytime.

1 Like

I get the same issue with you - the 3.8.2 source is ok, but the 3.9.2 source has the problem.

1 Like

Error: Could not find or load main class src.java.org.jivesoftware.openfire.starter.ServerStarter is the error I get when I run the project after following the same document instructions.

Then if remove ‘src.’ off the front of my main class in the run config I receive “A Java Exception has occured” error. Then the console returns:

Exception in thread “main” java.lang.SecurityException: Prohibited package name: java.org.jivesoftware.openfire.starter

at java.lang.ClassLoader.preDefineClass(ClassLoader.java:658)

at java.lang.ClassLoader.defineClass(ClassLoader.java:794)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)

at java.net.URLClassLoader.access$100(URLClassLoader.java:71)

at java.net.URLClassLoader$1.run(URLClassLoader.java:361)

at java.net.URLClassLoader$1.run(URLClassLoader.java:355)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:354)

at java.lang.ClassLoader.loadClass(ClassLoader.java:425)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)

at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)

The problem appears with this commit:

https://github.com/igniterealtime/Openfire/commit/4e4ec0b4221577952e7660a0fe3043 e5b75b2a65

I suspect that the problem is caused by not storing the .java files for the jitsivideobridge plugin in a src/java folder.

Try doing a fresh clone, then delete the jitsivideobridge plugin folder, then try to create your project. That worked for me.

Image2.jpg

In the most recent revision, the problem still lies with the jitsivideobridge folder. Specifically, deleting the .java files in:

src/plugins/jitsivideobridge/src/apps/spark/src/classes/org/jivesoftware/spark/p lugin/jitsivideobridge

will remedy the problem, and Eclipse finds the source folders correctly.

ok. thanks. I have zipped the folder into src.zip and deleted it