powered by Jive Software

Empty roster with daily build

With Jan. 12’‘s daily build, my roster is empty. This also occured with Jan. 11’'s build. I can try the other build to see whether it occurs there also.

The Jabber server I’'m using is charente.de, a Jabberd 1.4cvs-ipv6 server.

roster.getUnfiledEntryCount() == 0

roster.getGroupCount() == 0

When using the debugging window, ‘‘All Packets’’ shows ohly one RosterPacket with type result. On the ‘‘Raw Received Packets’’ tab, i can see my complete roster.

Also, I sometimes get this exception:

java.lang.ArrayIndexOutOfBoundsException: 1
     at javax.swing.plaf.basic.BasicTabbedPaneUI.paintTabArea(Unknown Source)
     at javax.swing.plaf.basic.BasicTabbedPaneUI.paint(Unknown Source)
     at javax.swing.plaf.ComponentUI.update(Unknown Source)
     at javax.swing.JComponent.paintComponent(Unknown Source)
     at javax.swing.JComponent.paint(Unknown Source)
     at javax.swing.JComponent.paintChildren(Unknown Source)
     at javax.swing.JComponent.paint(Unknown Source)
     at javax.swing.JComponent.paintChildren(Unknown Source)
     at javax.swing.JComponent.paint(Unknown Source)
     at javax.swing.JLayeredPane.paint(Unknown Source)
     at javax.swing.JComponent.paintChildren(Unknown Source)
     at javax.swing.JComponent.paintWithOffscreenBuffer(Unknown Source)
     at javax.swing.JComponent.paintDoubleBuffered(Unknown Source)
     at javax.swing.JComponent.paint(Unknown Source)
     at java.awt.GraphicsCallback$PaintCallback.run(Unknown Source)
     at sun.awt.SunGraphicsCallback.runOneComponent(Unknown Source)
     at sun.awt.SunGraphicsCallback.runComponents(Unknown Source)
     at java.awt.Container.paint(Unknown Source)
     at sun.awt.RepaintArea.paint(Unknown Source)
     at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
     at java.awt.Component.dispatchEventImpl(Unknown Source)
     at java.awt.Container.dispatchEventImpl(Unknown Source)
     at java.awt.Window.dispatchEventImpl(Unknown Source)
     at java.awt.Component.dispatchEvent(Unknown Source)
     at java.awt.EventQueue.dispatchEvent(Unknown Source)
     at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
     at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
     at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
     at java.awt.EventDispatchThread.run(Unknown Source)

I’'m using rather simple code:

try {
     XMPPConnection con = new XMPPConnection(HOST);
     con.login(USER, PASS);      Roster roster = con.getRoster();
     if (roster == null) {
          System.out.println("Empty roster");
     } else {
          Iterator it;
          
          System.out.println("Unfiled: " +roster.getUnfiledEntryCount());
          
          it = roster.getUnfiledEntries();
          while (it.hasNext()) {
               System.out.println("\t" +it.next());
          }
          
          System.out.println("Groups: " +roster.getGroupCount());
          
          it = roster.getGroups();
          while (it.hasNext()) {
               System.out.println("\t" +it.next());
          }
     }
     
     con.close();
} catch (XMPPException e) {
     // TODO Auto-generated catch block
     e.printStackTrace();
}

Note: notice how the first letters of both code-sections are removed. :-p

Bart,

I solved the problem with the Roster. You can find the fix in the next daily build. Let us know if it worked for you.

Regarding the debugger’'s exception, what platform are you using? Could you provide me a step-by-step procedure to reproduce the problem.

Thanks,

– Gato

Alright, I’'ll check it tomorrow.

I’‘m using “Java™ 2 Runtime Environment, Standard Edition (build 1.4.2-beta-b19)” on Windows XP and Eclipse 3.0 M6 (don’'t think that has anything to do with it).

I’‘m not sure how to reproduce it really, it just happens occasionaly when running the code in my fist message. I can try upgrading my JDK, maybe that’'ll solve it.

I’‘m using WinXP, Eclipse 2.1 and JDK 1.4.1_03 so I wouldn’‘t bet that it’'s a problem with the environment. The next daily build also includes some modifications and fixes on the debugger.

To be clear…are you just opening the debugger with one connection and sending messages? So you are not clicking on the tabs? You are just in the “All Packets” pane?

Thanks,

– Gato

That’'s correct, a single connection, and only the ‘‘All Packets’’ tab is used.

Edit: I should add that I can use the debug window as if nothing went wrong, or at least so it seems to me.

Message was edited by: nephilim

Just tried the new build and both my problems seem to be fixed.

Thanks Gato!

Bart,

Great! Let me know if the debugger’'s exception appears again.

Thanks,

– Gato