Enterprise Dashboard - Broken Images, No Stats


We’ve just upgraded from Openfire 3.3.x to Openfire 3.4.1 with the Enterprise plugin.

Following the upgrade, our enterprise dashboard and report page has broken images and “0” statistics. The only area that appears to be functioning is the current conversation list.

Any thoughts?

I’m guessing this is related… see attached error log snippet.

I just tried the following steps, and still no luck (with same errors appearing in logs)

  1. Reinstalled Openfire 3.4.1 (Windows Server 2003, with SQL Server backend)

  2. Uninstalled Enterprise Plugin 3.4.1 from Web Console, Plugin removed successfully

  3. Stopped Openfire Service

  4. Started Openfire Service

  5. Installed the Enterprise Plugin 3.4.1 from the Web Console’s “Try” the enterprise server tab

  6. Still broken.

Same here…Openfire Enterprise 3.3.3 displayed stats just fine, but I get no stats and no graphs after updating to 3.4.1. I did a tar.gz upgrade on Linux with MySQL…everything else is working great, though!

Looks like I forgot to import the proper SQL file from plugins/enterprise/database…after I did that and restarted the server, I’ve got stats coming up again.


If I perform the following SQL query, “select * from jiveversion”, I receive the following:

name, version

enterprise, 7

openfire, 13

What version does your enterprise return?

I manually applied the updates for version 8, 9, and 10. The SQL Server script to bring it up to version 8 wouldn’t work, so I manually made the adjustments in Enterprise Manager. I believe we’re now up to version 10 for Enterprise, however we still seem to have the same issue.

I’ve got:

openfire, 13

asterisk-im, 2

gateway, 4

enterprise, 7

sip, 1

I’m still seeing the same errors… and the non-functioning stats. ?:expressionless:

Hmm…that’s weird. That’s the only thing I did, and the stats started showing up. I’ll upgrade my Enterprise version to 10 and see what happens.


I dropped our SQL database, and uninstalled our Openfire installation. I then renamed the C:\Program Files\Openfire directory, and installed a fresh installation.

I created a brand new Openfire database using the script within the 3.4.1 Windows exe.

After following through the initial installation, I proceeded to install the enterprise plugin from the ‘available plugins’ section of the admin console. I pasted my enterprise license, which I obtained a fresh 3.4.1 version from jivesoftware.com.

The enterprise dashboard was still broken. We restarted everything, and the enterprise dashboard of a fresh installation is still broken.

Platform: Windows Server 2003, SQL Server 2000.

Error log attached.

I’ve done everything and the images are still broken.

Is there a “entrrds” table in your database? If so, are there any records in it?

My SQL Server does have an entRRDs table. It is empty.

This appears to be an Openfire Enterprise bug with installing on MS SQL Server. I have logged the bug at http://www.igniterealtime.org/issues/browse/ENT-259

The problem is with the data type of the “bytes” field in the “entRRDs” table - the type is set as TEXT but should be IMAGE.

To get around this, stop your Openfire server and drop the entRRDs table from your database. Then recreate it but use this SQL to do so:



updatedDate BIGINT NOT NULL,




Now the “bytes” field is of the IMAGE data type and you should see images show up correctly in the Enterprise Dashboard.

Magic! We’re back in action… Thank you!

Just wanted to say thanks for this post. This fixed my issue with Openfire 3.5.0 and MS SQL Express.