powered by Jive Software

ERRO AO INICIAR Openfire 4.2.3 COM MySQL

Boa tarde Pessoal, realizamos a instalação a instalação do Openfire 4.2.3 COM MySQL com integração ao nosso AD, na console do Openfire é possível ver todos os GRUPOS e USUÁRIOS do meu AD com sucesso, porem ao iniciar o meu Openfire aparece a seguinte MENSAGEM:

“Mon Apr 02 10:33:38 BRT 2018 WARN: Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to ‘false’. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Mon Apr 02 10:33:38 BRT 2018 WARN: Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to ‘false’. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Mon Apr 02 10:33:38 BRT 2018 WARN: Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to ‘false’. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Mon Apr 02 10:33:38 BRT 2018 WARN: Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to ‘false’. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Mon Apr 02 10:33:38 BRT 2018 WARN: Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to ‘false’. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Openfire 4.2.3 [02/04/2018 10:33:40]
Successfully loaded plugin ‘admin’.
Successfully loaded plugin ‘search’.
Finished processing all plugins.
Error starting 5222: Address already in use: bind
Error starting 5223: Address already in use: bind
Error starting 5269: Address already in use: JVM_Bind
Error starting 5275: Address already in use: bind
Error starting 5276: Address already in use: bind
Error starting 5262: Address already in use: bind
Error starting 5263: Address already in use: bind”

e nos computadores Clientes fizemos a instalação do spark_2_8_3 e informa: Unable to verify certificate

Alguém poderia me ajudar por gentileza?

Not sure about that MySQL warning, never seen such.

Error starting 5222: Address already in use: bind

This error is because Openfire is already installed and running as a Windows service and you run it again via Openfire Launcher and it can’t connect to 5222 port. DON’T USE THE LAUNCHER. Or stop and disable Openfire service, if you really want to use the launcher.

If your server is named e.g. “servername” and you are using different name or IP in Spark to connect, there is a mismatch in domain names and Spark can’t determine whether your SSL certificate is trusted. You should fix your server’s name or use its name instead of IP address to connect (you might need to create DNS entries for that). If you don’t want/can’t do that, go to Advanced settings on Spark’s login screen and enable both Accept all certificates and Disable certificate hostname verification options.

1 Like

Thanks for the feedback. Actually the service was already running on windows, I will perform the other tests and soon I will communicate.