powered by Jive Software

Error in Wildfire and SSL question

When i setup a test user and try to connect to my server i see this error in the Wildfire window:

Exception in thread “pool-2-thread-1” java.lang.NullPointerException

at org.jivesoftware.wildfire.spi.RoutingTableImpl.getRoute(RoutingTableImpl.java:8 3)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.returnErrorToSender(Out goingSessionPromise.java:153)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$400(OutgoingSess ionPromise.java:37)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:94)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

And the client can’'t connect.

The Client takes ages to connect and is getting errors like:

“SSL Security Warning: The SSL certificate received from the server has errors…”

or “An error occured trying to register your new account. This server may not allow open registration”.

Anyway this is just a small environment here, no serious security is necessary.

Is it possible to just not require SSL?

Using Wildfire 2.4.2 and Exodus 0.9.1.0

Hi,

to disable SSL open http://127.0.0.1:8080/wildfire/ssl-settings.jsp (Security Settings in your admin console, maybe another port+ip) and select “Custom” and “Not available” for SSL and TLS.

LG

LG

is it http://127.0.0.1:8080/wildfire/ssl-settings.jsp or http://127.0.0.1:9090/wildfire/ssl-settings.jsp ? Can’'t access both though. The second one give error like this

HTTP ERROR: 404

/wildfire/ssl-settings.jsp

RequestURI=/wildfire/ssl-settings.jsp

Powered by Jetty://

I think that you mean http://127.0.0.1:9090/ssl-settings.jsp ,

Regards,

wmhtet

Hi wmhtet,

well, one should give some exercises to the reader this is my Tomcat/wildfire.war URL.

LG

Hey guys,

I just entered a quick fix for the NullPointerException exception. The bug fix will be included in today’'s release of Wildfire 2.4.3.

Thanks,

– Gato

Uh

I forgot that we have a tomcat installation, I noticed that it is the tomcat port though. For me I prefer to separate the two instances while running wildfire without tomcat is not very hard.

wmhtet