Error installing Spark-2.6.3 on Fedora 16

Not yet…I am under the gun on a project and will have to come back to this in a couple of days. For now I have installed Spark in my Windows VM as a workaround. (this is a work laptop)

ah i see… ok, well when u revisit this, let us know. i’m curious as to what is holding it up. if i rememebr tonight i’ll zip up my working installation on my Fedora16 laptop and upload it someplace… you should be able to download it and unzip it and compare to your installation… as mine is confirmed working. maybe it will help?

Hi All,

i’m facing exact same problem with spark 2-7-6, (in the lab environment)…tried steps suggested by James, any help i’ll appreciate.

[admin@centos ~]$ sudo sh

[sudo] password for admin:

sh-4.2# cd Downloads

sh-4.2# ls -l

total 331220

-rw-rw-r–. 1 admin admin 4256 Mar 20 01:21 adobe-release-x86_64-1.0-1.noarch.rpm

drwxr-xr-x. 8 admin admin 4096 Mar 16 01:46 firefox

-rw-rw-r–. 1 admin admin 51233375 Mar 20 00:22 firefox-45.0.1.tar.bz2

-rw-rw-r–. 1 admin admin 7258838 Mar 20 01:35 flash-plugin-

-rw-rw-r–. 1 admin admin 96790574 Mar 19 16:59 openfire-4.0.1-1.i386.rpm

drwxrwxrwx. 11 admin admin 4096 Mar 15 21:36 Spark

-rw-rw-r–. 1 admin admin 68604713 Mar 19 22:45 spark-2.7.6.rpm

-rw-rw-r–. 1 admin admin 114599101 Mar 20 02:08 spark_2_7_6.tar.gz

drwxrwxr-x. 2 admin admin 4096 Jul 14 2008 sparkweb

-rw-rw-r–. 1 admin admin 645614 Mar 19 23:28

sh-4.2# rpm -Uvh spark-2.7.6.rpm

error: Failed dependencies: is needed by Spark- is needed by Spark-

sh-4.2# sudo yum install flash-plugin

Loaded plugins: fastestmirror, langpacks

Loading mirror speeds from cached hostfile

Package flash-plugin- already installed and latest version

Nothing to do

sh-4.2# sudo yum install java

Loaded plugins: fastestmirror, langpacks

Loading mirror speeds from cached hostfile

Package 1:java-1.8.0-openjdk- already installed and latest version

Nothing to do



sh-4.2# java --version

Unrecognized option: --version

Error: Could not create the Java Virtual Machine.

Error: A fatal exception has occurred. Program will exit.

sh-4.2# chmod 777 Spark

sh-4.2# ls

adobe-release-x86_64-1.0-1.noarch.rpm firefox-45.0.1.tar.bz2 openfire-4.0.1-1.i386.rpm spark-2.7.6.rpm sparkweb

firefox flash-plugin- Spark spark_2_7_6.tar.gz

sh-4.2# cd Spark

sh-4.2# ls

bin documentation jre lib logs plugins resources Spark starter xtra


sh-4.2# ./Spark

sh-4.2# ./starter

nothing after this, something should launch…i recently started using centos, previously had ubuntu.

any step i am missing…thanks.

This is a long standing issue with dependencies for rpm install. But we don’t have experienced developers or RPM based OS users to fix this. Filed as [SPARK-1717] Failing dependencies when installing RPM version - Jive Software Open Source

On Ubuntu, when i use tar.gz version i have to go inside and do chmod +x Spark. When you do ls in that directory, does it list Spark and starter as executable files?

yes, it did show me highlighted in green after i did chmod stuff,



i did these too…no response at all.

with ubuntu i have done various program installations, basically .bin specially and i was expecting some GUI to popup or something rolling in terminal…but nothing happened. Unfortunately, i did least of rpm packages install, could there be an older version which i can try(if that is less problematic.

i’m mainly a cisco UC engineer and linux loving guy, who uses mostly anything other than windows. of course willing to learn opensource.

using my MAC book pro running osx el capitan the spark-2-7-6.dmg worked perfectly. when i tried on windows 7 machine, spark-2-7-6.exe was installed successfully but after login the IM was logging out on its own every 3 sec or so.

Also to add, i couldn’t get spark web to work on any platform…java/flash i had updated before…

any help suggestion to test/learn spark with some stable operation…any old version more stable to invest some learn time.

SparkWeb is outdated and unsupported, not worth trying. Also it’s a web client which should be installed on the server itself, not on the client machine. Trying older Spark version not worth it either. It will have the same issue with rpm and even more other bugs. I wil ltry to look into dependencies issue later, but can’t promise anything. Not a huge linux guy, nor good java developer

Hi, mandy,

Could you please test those RPM builds and see if it fixes the issues.

  1. build 797 x86_64 (added missing libraries) [SPARK-1717] Failing dependencies when installing RPM version - IgniteRealtime JIRA

  2. build 800 x86_64 (also removed old java from the RPM, wonder how it installs and works now) [SPARK-1718] Remove old java from RPM installation - IgniteRealtime JIRA