powered by Jive Software

Error: object does not represent a valid JID

Yah, I got an answer from the collab.netbeans.org Mailing List. Zachary Benz told me that it is a known issue that OpenFire 3.4.x isn’t working with the collaboration of netbeans. We should use Openfire 3.3.x instead.

Thanks!

For you information, I got an answer here

http://blogs.sun.com/roumen/entry/using_developer_collaboration_behind_firewall# comments

that NetBeans 6.1 will fix the current issues.

According to “http://wiki.netbeans.org/wiki/view/NB61PerfPlan” the final release date for NetBeans IDE 6.1 is april the 21th.

org.jivesoftware.openfire.spi.PresenceManagerImpl.userUnavailable(PresenceManage rImpl.java:268)

Error storing offline presence of user: xxxxxxxx

java.sql.SQLException: Unique constraint violation: SYS_IDX_51 in

statement [INSERT INTO jivePresence(username, offlinePresence,

offlineDate) VALUES(?,?,?)]

at org.hsqldb.jdbc.Util.throwError(Unknown Source)

This error is still occurs in v1.3 on the netbeans 6.1 build, has the underlying schema changed?, are in active users not being cleaned out?

anyone got any ideas?

you can solve this: (Please add to faq) check this: - username must be in lowercase (on server and in collab login)
- change the domain to a name with a dot: mypc.org
- change the hostname at loginscreen also to: mypc.org so that the login goes to [user.name@mypc.org]
openfire domain setting: open admin console under localhost:9090
-> Server
-> Servermanager
-> System Properties
-> xmpp.domain
edit the domain to a domain with a dot

tried the solution that you have suggested, the domain was already in the format sungrid1.xxxxxxxxxx.com.au , tried username with and without the dot and stilll end up with the same error Thanks

local maschine responds to this domain?

check if you setup it in both?

maybe you need to restart the openfire server after changing the values? (i remember i miss this point after my first trials of changing the settings and i loose many hours)

Finally got the time to do some more investigation…

The error still exists see below…

info.log

2008.07.30 14:06:53 Openfire stopped
2008.07.30 14:06:53 Server halted
2008.07.30 14:07:19 Multi User Chat domain: conference.sungrid1.xxxxxx.com.au
2008.07.30 14:07:20 Publish-Subscribe domain: pubsub.sungrid1.xxxxxx.com.au
2008.07.30 14:07:20 Openfire 3.5.1 [Jul 30, 2008 2:07:20 PM]
2008.07.30 14:07:22 Admin console listening at:
http://sungrid1.xxxxxx.com.au:9090
https://sungrid1.xxxxxx.com.au:9091
2008.07.30 14:07:22 Started server (unencrypted) socket on port: 5269
2008.07.30 14:07:22 Started plain (unencrypted) socket on port: 5222
2008.07.30 14:07:22 Started SSL (encrypted) socket on port: 5223

error.log

2008.07.30 14:07:40 [org.jivesoftware.openfire.spi.PresenceManagerImpl.userUnavailable(PresenceMana gerImpl.java:268)] Error storing offline presence of user: tim.davenport
java.sql.SQLException: Unique constraint violation: SYS_IDX_51 in statement [INSERT INTO jivePresence(username, offlinePresence, offlineDate) VALUES(?,?,?)]

at org.hsqldb.jdbc.Util.throwError(Unknown Source)
at org.hsqldb.jdbc.jdbcPreparedStatement.execute(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.ja va:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.logicalcobwebs.proxool.ProxyStatement.invoke(ProxyStatement.java:100)
at org.logicalcobwebs.proxool.ProxyStatement.intercept(ProxyStatement.java:57)
at $java.sql.PreparedStatement$$EnhancerByProxool$$50ae6914.execute()
at org.jivesoftware.openfire.spi.PresenceManagerImpl.userUnavailable(PresenceManag erImpl.java:265)
at org.jivesoftware.openfire.handler.PresenceUpdateHandler.process(PresenceUpdateH andler.java:145)
at org.jivesoftware.openfire.handler.PresenceUpdateHandler.process(PresenceUpdateH andler.java:112)
at org.jivesoftware.openfire.handler.PresenceUpdateHandler.process(PresenceUpdateH andler.java:176)
at org.jivesoftware.openfire.PresenceRouter.handle(PresenceRouter.java:134)
at org.jivesoftware.openfire.PresenceRouter.route(PresenceRouter.java:70)
at org.jivesoftware.openfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:76)
at org.jivesoftware.openfire.SessionManager$ClientSessionListener.onConnectionClos e(SessionManager.java:1133)
at org.jivesoftware.openfire.nio.NIOConnection.notifyCloseListeners(NIOConnection. java:183)
at org.jivesoftware.openfire.nio.NIOConnection.close(NIOConnection.java:166)
at org.jivesoftware.openfire.session.LocalSession.close(LocalSession.java:303)
at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:120)
at org.jivesoftware.openfire.nio.ConnectionHandler.messageReceived(ConnectionHandl er.java:133)
at org.apache.mina.common.support.AbstractIoFilterChain$TailFilter.messageReceived (AbstractIoFilterChain.java:570)
at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:299)
at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:53)
at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:648)
at org.apache.mina.common.IoFilterAdapter.messageReceived(IoFilterAdapter.java:80)
at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:299)
at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:53)
at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:648)
at org.apache.mina.filter.codec.support.SimpleProtocolDecoderOutput.flush(SimplePr otocolDecoderOutput.java:58)
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF ilter.java:180)
at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:299)
at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:53)
at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:648)
at org.apache.mina.filter.executor.ExecutorFilter.processEvent(ExecutorFilter.java :239)
at org.apache.mina.filter.executor.ExecutorFilter$ProcessEventsRunnable.run(Execut orFilter.java:283)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java: 885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:51)
at java.lang.Thread.run(Thread.java:619)

Anyone got any more ideas what causes this error

Error storing offline presence of user: ian
java.sql.SQLException: Unique constraint violation: SYS_IDX_51 in statement [INSERT INTO ofPresence(username, offlinePresence, offlineDate) VALUES(?,?,?)]

I’m running Openfire 3.6 and Netbeans 6.1.

HSQL is the backend database.

Netbeans reports “object does not represent a valid JID” although I think the Openfire error above is the real problem.

Ian

Please follow all the steps descripted in this page:
http://wiki.netbeans.org/CollabServer

  1. Download the las openfire server.
  2. Install.
  3. Open admin console.
  4. Check for the search plugin (Plugin’s Tab)
  5. In the Conferences Tab, click in the link for the default conference.
  6. Delete and destroy the service.
  7. Create a new conference service** with another name** (name!=“conference”).
  8. Create a new Chat room.
  9. Make this chat room public and allow to users to invite to another users.

Ok, all’s right to here, now, to create a new user (using Netbeans or the admin console).

Create a group and add the user’s created to this group.
Enable contact list sharing
Mark “Share group with additional users” and then “all users”.

This steeps work for me.
I’m Using window’s version for the server, Netbeans 6.5.1 and a MySQL database, all installed locally.

Hello.

It seems that the problem is a netbeans bug.

I installed openfire in my machine (Windows XP x64) and I´m able to connectd locally and remotely with netbeans.

So, I installed openfire in my server (Ubuntu x64), I performed every configuration described here (http://wiki.netbeans.org/CollabServer),,) like I did in my machine. When I try to connect the problem appears.

To verify if it´s a netbeans or a openfire problem I downloaded spark client. When I tried to connect in my server it worked fine. So, I think that this is a problem with netbeans’s developer collaboration plugin.

Does anybody knows what to do?

[]´s

The following work-around ‘fixed’ the issue at the expense of some lost functionality:

Server Settings > Offline Messages

Set to the ‘Offline Message Policy’ to ‘Bounce’ or ‘Drop’

Current setup:

OpenFire 3.6.3 on CentOS 5.2.

NetBeans 6.1, 6.5 on both Windows and Linux worked.

Hi Deryl.

Yout work around didn´t work for me…

I have the same error… Im using openfire 3.6.3

[]´s

Hi.

I have a mac 10.5, win xp pro sp2, ubuntu itrepid ibex.

All have installed netbeans 6.5.1 and 6.1.

But i cannot connect via developer collorbration BUT i can connect via spark the openfire client.

when i look at the ide log i see:

com.sun.collablet.CollabException: object does not represent a valid JID
at org.netbeans.modules.collab.provider.im.IMCollabManager.createSession(IMCollabM anager.java:340)
at org.netbeans.modules.collab.ui.DefaultUserInterface$LoginTask.run(DefaultUserIn terface.java:1508)
at java.lang.Thread.run(Thread.java:619)

which does in deed mean its a nebeans, plugin bug.

Hope this helps.

follow up even if i install developer collaboration on netbeans 6.1 it still dont work.

Tip have a look at the top of your ide log does it say error about e.g. missing j2se?

I’m checking out if it is creating this.

Try netbeans 6.7M3 it worked for me BUT you may have to click connect (no mater the error) a few times.

First of all, im not i Linux-guru, but i finally managed to get it working for me.

My situation:

  • NetBeans with Collaboration plugin on my local (windohs xp) machine, trying to connect to a Ubuntu 8.10 server (accessible through lan) with openfire installed.

I’ll swiftly explain my process: First i thought it was a version problem, that the newest version of openfire (3.6.4) wouldnt work with my version of NetBeans(6.5.1). I tried openfire version 3.6.3 and it didn’t work. I went as low as version 3.5.0 and that didnt work either. I started suspecting that, well maybe its more of an database problem?

I allready had a mysql server up and running on my ubuntu server, so why not just create a new database in mysql for openfire to use? So i configured a new database named openfire, reinstalled openfire (3.6.3) with settings to connect to my mysql dabatase. Opened Netbeans, created a new user, and tried to connect, and yeah; no more error messages.

So, don’t use that crappy default local database server, use mysql, and maybe you will get it working as i did.

Another thing, if you want to try different versions of openfire. Just replace the version numbers you would like to download in the following url, for example:

http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire_3.6.3_all.deb

http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire_3.5.0_all.deb

http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire_3.6.0_all.deb

Hi jopes,

I don´t think so. I´m using a mysql database from the beginning.

[]´s

Oh, well. Just trying to help.

Im sorry to say this but I have all 3 platforms and 3 differnt versions of netbeans, used 2 different vesions of openfire and I have to say with and without mysql it still comes up.

It is NOT a database problem.

I belive the server is not at fault either.

To my knowledge Is in a bug in netbeans plugin. It is not configured of programmed currectly.

Well I can be wrong but…

Well someone please look into this.

Hi all,

i have successfully manged to login from Netbeans to Openfire and use the collaboration feature.

I installed the latest Netbeans 7.0 Milestone 2. I think you first have to install the collaboration feature from the available plugins list. I installed Openfire 3.7.0 Beta from the nightly builds (openfire_2010-11-01.tar.gz) on Ubuntu 10.10 (amd64) and placed the installation in /opt/openfire. I changed the user/group owner to openfire:openfire. During installation i followed the instructions in /opt/openfire/documentation/install-guide.html (Running Openfire in Linux/Unix) and on http://wiki.netbeans.org/CollabServer (Point 2 and 3).

You can start the openfire installation with the script openfire.sh in the bin/openfire folder of your openfire installation. Wait a few seconds and the server will start.

I have an dyndns account and tried to login from netbeans, using my domain name (eg. mydomain.homeip.net) in the properties field ‘Server’ of the Account Management. This won’t work. You have to use a ip address and append the port number to it, eg. 77.10.112.245:5222.