powered by Jive Software

Error report, half way done :)

Hi there!

I’m absolutely desperate to get the first video chat running on the plugin for openfire 3.9.1.

I thinks it’s such a cool thing to have and use! Thanks for all your effort

Maybe I can help to get things “smoother” and provide some error report…

  1. I’ve installed 3.9.1 on a linux vm,

  2. I’ve installed the plugin “Jitsi Video Bridge”, (the configuration dialog appeared in the webinterface where you can decide which ports)

  3. I’ve installed Chrome to do some testing and set it to debug(–enable-logging --v=1)

  4. I’ve connected to the URL where it should be running (and SOMETHING is actually running, have a look at the screenshot ofmeet.png)

  5. I’ve examined the Chrome logs, but it’s absolutely not clear to me whats the problem here.(I’ve attached the relevant part of the log)

I’m also watching openfire logs on the second screen but, as far as I can tell, nothing of interest there.

I’m also watching iptables to be sure nothing important gets dropped… and nothing gets dropped.

(I’ve setup a rule to allow all from my client-ip).

I’ve verified chrome works with meet.jit.si, and at least I can see myself there

Kind regards

see

http://community.igniterealtime.org/community/support/jitsi_videobridge_plugin/b log/2014/02/08/configure-ofmeet-first-before-trying-to-create-a-videoconference

Hi there!

Thank you very much for your fast reply! I’ve opened config.js but it seems pretty much self configuring:

var config = {
    hosts: {
        domain: window.location.hostname,
        muc: 'conference.' + window.location.hostname, // FIXME: use XEP-0030
        bridge: 'jitsi-videobridge.' + window.location.hostname // FIXME: use XEP-0030
    },
    useIPv6: false, // ipv6 support. use at your own risk
    useNicks: false,
    useWebsockets: true,
    resolution: "360",
    bosh: window.location.protocol + "//" + window.location.host + '/http-bind/' // FIXME: use xep-0156 for that
};

But I’ll give it a try and create a new config.js with the content you’ve provided to me. (with modified settings, of course)

I’ll report back soon.

Ok, modifying the config.js did the trick, now I can Video- and Voice- chat with clients located at the same network. GREAT

(Though I had to do some minor changes to the config you’ve posted, I pointed them out in the comments of your blogpost)

Though it’s not possible to connect users from outside lan.

They can access the website, can use the webchat but the video screen stay black.

( i think there was also no audio, but I’m not sure on this)

I was sitting at my firewall watching logs and there were “obscure” packets like the openfire server was trying to send packets to the internal ip address(192.168.x.x) of the user that tried to connect externally.

(udp packets only)

i’m having the exact same grey screen thing you had. i’ve tried all sorts of changin of the config.js file but no joy.

is there any chance you can post your working file so i can copy it for my install?

Yes, here u go:

Sorry for the delay. Weekend, Friends …

var config = {
    hosts: {
        domain: 'MYDOMAIN.TLD',
        muc: 'conference.MYDOMAIN.TLD',         bridge: 'jitsi-videobridge.MYDOMAIN.TLD'     },
    useIPv6: false, // ipv6 support. use at your own risk
    useNicks: false,
    useWebsockets: false,          // change this if you have websockets plugin for openfire
    resolution: 360,
    bosh: window.location.protocol + "//" + window.location.host + '/http-bind/' };

This is the config I’m working with.

Kind regards!

thanks!

ok ive now established that i dont have websockets installed so will read up on that one next. in the meantime i’ve set it to false.

i’m still confised with what i should put in the bosh line though? what is window.local.host.protocol meant to be? is it just 7070? could you let me know with an example please?

at the moment when i try to go to the page i get this in the debug window and the same grey screen:

Failed to load resource: the server responded with a status of 404 (Not Found)

https://jabber.saxonweald.com:7443/ofmeet/undefined//jabber.saxonweald.com:7443/ http-bind/

I am experiencing the same problem… No solution for the moment, I can’t do any conference with clients and even for screenshare.

hi babyface - i’ve just updated to 1.1.1 version and installed websockets as per dele’s other post:

http://community.igniterealtime.org/community/support/jitsi_videobridge_plugin/b log/2014/02/09/jitsi-videobridge-plugin-ver-111

now things are looking much more promising! i’m getting the video come through locally - i’ll try it for real when i get another client rigged up at work tomorrow

Hi chik,

me too I can see myself on vidéo but when someone join the room I cannot see him and he cannot see me even but each can see itself.

screenshare is the same. I think that it is the same problem.

When I try with url &screen=true and ip address without changing config.js I can see my desktop shared but only my desktop no video.