Error when synching with AD

We are trying to synch with AD and keep getting the following message:

Failed to create new connections on startup. Attempt 0 of 3

java.sql.SQLException: The database is already in use by another process: org.hsqldb.persist.NIOLockFile@c798e4a6[file =C:\Program Files\Wildfire\embedded-db\wildfire.lck, exists=true, locked=false, valid=false, fl =null]: java.lang.Exception: The process cannot access the file because another process has locked a portion of the file : C:\Program Files\Wildfire\embedded-db\wildfire.lck

at org.hsqldb.jdbc.Util.sqlException(Unknown Source)

at org.hsqldb.jdbc.jdbcConnection.(

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.wildfire.starter.ServerStarter.start(

at org.jivesoftware.wildfire.starter.ServerStarter.main(

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)

We have rebooted the server and still get this error. Any suggestions would be great!

Hey bandit,

Since your question is marked as answered i guess that you already solved this issue. The common reason for this problem is that the lock file used by the embedded DB was not removed when the server was stopped. That may happen when the server process is just killed. Removing the wildfire.lck file before starting up the Wildfire server solves this problem.


– Gato