powered by Jive Software

Error when trying to add a contact

Internal server error

org.jivesoftware.wildfire.user.UserAlreadyExistsException: student1@test-xmpp-win

at org.jivesoftware.wildfire.roster.RosterItemProvider.createItem(RosterItemProvid er.java:113)

at org.jivesoftware.wildfire.roster.Roster.provideRosterItem(Roster.java:275)

at org.jivesoftware.wildfire.roster.Roster.createRosterItem(Roster.java:219)

at org.jivesoftware.wildfire.roster.Roster.createRosterItem(Roster.java:206)

at org.jivesoftware.wildfire.handler.PresenceSubscribeHandler.manageSub(PresenceSu bscribeHandler.java:230)

at org.jivesoftware.wildfire.handler.PresenceSubscribeHandler.process(PresenceSubs cribeHandler.java:96)

at org.jivesoftware.wildfire.PresenceRouter.handle(PresenceRouter.java:116)

at org.jivesoftware.wildfire.PresenceRouter.route(PresenceRouter.java:61)

at org.jivesoftware.wildfire.PacketRouter.route(PacketRouter.java:73)

at org.jivesoftware.wildfire.net.SocketReader.processPresence(SocketReader.java:44 4)

at org.jivesoftware.wildfire.net.ClientSocketReader.processPresence(ClientSocketRe ader.java:56)

at org.jivesoftware.wildfire.net.SocketReader.readStream(SocketReader.java:241)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:119)

at java.lang.Thread.run(Unknown Source)

2006.01.27 17:26:55 [org.jivesoftware.wildfire.handler.PresenceSubscribeHandler.process(PresenceSub scribeHandler.java:171)

I tried reinstalling wildfire and using different clients, the only thing that stayed the same is the database (in which I deleted all tables wildfire uses and then recreated them). Any iideas?

This error has to mean something to somebody…I have a meeting later this week and I need to demo this server and I cant do that if its not working.

Hi Jason,

the UserAlreadyExistsException should only be thrown if one tries to create a roster for a user which already has a roster. That’'s the SQL statement which fails:

“INSERT INTO jiveRoster (username, rosterID, jid, sub, ask, recv, nick) VALUES (?, ?, ?, ?, ?, ?, ?)”

Is your JIVEROSTER table empty?

When does this error occur?

LG

Yes the JiveRoster Table is empty.

This error occurs when I attempt to add a user to my roster.

Hi,

I wonder whether your database also throws some errors. As a new installation is done very fast and your current installation seems to be unusable I wonder if you want to install Wildfire again, this time using the internal database.

Which database are you using?

LG

I have just reinstalled wildfire this morning.

I am using an SQL database.

I can create user accounts and see them being created in the JiveUser table, so its not a permission issue I dont think.

I will try the embedded database right now.

The problem appears to be with a specific server, aside from uninstalling wildfire is there anything else that needs done to completely remove any config files it may have left behind (other than deleting the program directory)?

I am reformatting that server right now and then I am going to try to install wildfire clean again. Could this possibly have anything to do with DNS?

OK I just formatted the server and reinstalled wildfire and that has fixed the problem. I dont know if it was some currupt java lib or something but the problem is now solved.