powered by Jive Software

Error when trying to edit shared roster group: 'fn:escapeXml'

Hello!

Problem: Cannot edit shared roster group.

Error: When trying to edit the shared roster group, the following error is generated by group-edit.jsp:

javax.servlet.ServletException: javax.servlet.jsp.JspException: javax.el.ELException: Problems calling function ‘fn:escapeXml’

[etc., etc.]

Caused by: javax.el.ELException: org.jivesoftware.openfire.user.UserNotFoundException: Cannot load user of remote server: user.name@remotedomain

[etc., etc.]

Details:

There were some users on another chat server of mine (‘remotedomain’) that I wanted to have in the shared roster group on this newer server until I got them moved over to the new server. So I added their JIDs to the new server’s shared roster group “Everyone.” And this works fine. I do want to note that this other server ‘remotedomain’ has no top-level domain — it is not Internet routable. I added ‘remotedomain’ to the server’s hosts file, routing it to the IP address of the other server.

I didn’t start getting the above error until I had moved one of the others from the ‘remotedomain’ server to the new server — user.name@remotedomain. The new server is im.newdomain.net. The username remained the same, so the new user created is user.name@im.newdomain.net.

I discovered this when I tried to go into edit the roster group to remove the related user.name@remotedomain from the shared roster group.

What I’ve Tried Already:

  • I’ve rebooted the server itself.
  • I’ve tried several different links/ways of editing the group from the admin console. All produce the same error.
  • There’s no way to remove a user from a shared roster group using the REST API that I know of.

I’d appreciate any help!!! Thanks in advance!

EDIT: Just wanted to mention that the user still exists on the other server, though I don’t think that would have anything to do with this error.

Openfire 4.1.5 is being used here?

It is.

The issue’s since been “resolved” because I moved everyone on the other server to the new server. Up until that point, however, it was still doing the same thing. For what it’s worth, during the transition, as soon as I disabled server2server, that group was able to be edited.