powered by Jive Software

Error while building OpenFire

Hi,

I tried to build OpenFire according to this tutorial: https://community.igniterealtime.org/docs/DOC-1020

It was quite hard because it is an old one but I’m almost there I think. The issue I have now is that when I try to run it, I get:

java.lang.SecurityException: Prohibited package name: java.org.jivesoftware.openfire.starter

at java.lang.ClassLoader.preDefineClass(Unknown Source)

at java.lang.ClassLoader.defineClassCond(Unknown Source)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.access$000(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

I read on the internet that it has to do with the fact that the class shouldn’t start with “java.” but I don’t know how to fix it and I didn’t find any explanation on how to do it.

Could someone guide me though?

Thanks

Hi,

hum… I just solved this specific issue by changing the source folder to java. However, I’m still unable to build. There are a lot of error but I think that the issue is Eclipse cannot find org.xmlPull. Isn’t it supposed to be included in the SVN repository?

Do I have to download it and include it to the project?

EDIT

OK… I included the org.xmlPull to my project but I still does not work…dom4j seems not to build because it cannot resolve “DocumentFactory”… What am I supposed to do…**
**