powered by Jive Software

Error while Loading shared libraries during Installation

Hello,

  1. Downloaded the install ( openfire-4.3.2-1.i686.rpm RPM (32bit JRE bundled) for Red Hat Linux and variantsJanuary 31, 2019) from https://www.igniterealtime.org/downloads/index.jsp.

  2. Rpm it on new server.

  3. I tried to start openfire to setup using this command

/opt/openfire/bin/openfire.sh start &

but I get this error

and as a result can’t setup from web-based wizard.

There’s no ld-linux.so.2 under /opt/openfire/lib . I then got a copy of this file from another server and copied it to the server am installing Openfire at /lib/ and run the command again.

This time I get this error

[root@CRGARCTHINS openfire]# /opt/openfire/jre/bin/java: error while loading shared libraries: libpthread.so.0: cannot open shared object file: No such file or directory

I again got a copy of ths file from another Linux server an copied to these directories

/lib64/libpthread.so.0
/lib64/tls/libpthread.so.0
/lib/libpthread.so.0
/lib/tls/libpthread.so.0
/lib/i686/libpthread.so.0

I tried starting Openfire again but the libpthread.so.0 remains.

Please advise what is needed to properly install Openfire

Thank You

What OS are you installing on?

Greetings, If you are on a 64bit OS, then you should install the 64bit RPM so that you get a 64bit JRE installed. In general though, you should use the noarch RPM and install your own vendor provided JRE.

daryl

[root@CRGARCTHINS openfire]# cat /etc/os-release
NAME=“Red Hat Enterprise Linux Server”
VERSION=“7.1 (Maipo)”
ID=“rhel”
ID_LIKE=“fedora”
VERSION_ID=“7.1”
PRETTY_NAME=“Red Hat Enterprise Linux”
ANSI_COLOR=“0;31”
CPE_NAME=“cpe:/o:redhat:enterprise_linux:7.1:GA:server”
HOME_URL=“https://www.redhat.com/
BUG_REPORT_URL=“https://bugzilla.redhat.com/

REDHAT_BUGZILLA_PRODUCT=“Red Hat Enterprise Linux 7”
REDHAT_BUGZILLA_PRODUCT_VERSION=7.1
REDHAT_SUPPORT_PRODUCT=“Red Hat Enterprise Linux”
REDHAT_SUPPORT_PRODUCT_VERSION=“7.1”
[root@CRGARCTHINS openfire]#

Have just tried this on a new RHEL 7.5 instance on AWS:

sudo yum install java-1.8.0-openjdk-devel
java -version (shows 1.8.0)
cd /home/ec2-user/
sudo yum install wget
wget https://github.com/igniterealtime/Openfire/releases/download/v4.3.2/openfire-4.3.2-1.noarch.rpm
sudo rpm -Uhv openfire-4.3.2-1.noarch.rpm – no errors (Openfire restarted with systemctl, the only output)
After updating AWS inbound rule i was still not able to login to Openfire’s web setup at http://publicip:9090
So i have restarted the server and then it was accessible (although it still didn’t show 9090 port via netstat, it shows up on Ubuntu machine though).

Anyway. Openfire should install the daemon and run it automatically. If it doesn’t, then try to restart the server. No need to run it manually via sh script. As i’ve said, i have tested on 7.5 as that’s what AWS has. Maybe older version is missing something or your system is modificated. Although all it should be needing is proper Java (8 only for now).

Hi,

Thank you for the feedback. I will give the above a go and see how it goes.

Hi,

Just an update on this matter.

I tried wroot suggestions but was still getting the same error with the library missing.

Seems by copying the missing libraries from an old server to this new server seems to eventually gave a serious issue on the new server as we were unable to ran any forms of simple commands from existing ssh session.

New SSH sessions would also fail. Server had to be taken down to RESCUE mode and we still could not run simple commands from command line. After doing a force delete the library with

rm -Rf /lib64/tls/lbpthread.so.0

Normal commands started working again. Server was rebooted and we could SSH as normal.

Instead of using the noarch RPM, I decided to use the 64bit RPM install. The install was successful.

From command line I manually started Openfire with the command

/opt/openfire/bin/openfire.sh start &

This time it came up with the url link to setup Openfire via browser.

From browser the setup worked successfully.

So for some reason it looked safer to use the 64bit RPM that has the 64bit JRE installed.

We thank everyone for their advice.

1 Like