powered by Jive Software

Exception in thread "main" SASL authentication failed

it is simple yet fails… server is wildfire 3.1.0 beta 3… any idea?

XMPPConnection connection = new XMPPConnection(“mac.local”);

connection.login(“u1@mac.local”, “u1”);

Did you try

XMPPConnection connection = new XMPPConnection(YOUR_IP_ADDRESS,5222); //or whatever your port number is.

connection.login(“u1”,“u1_password”);

I have a similar problem. I have encountered it intermittently running from within Eclispe and I get the failure everytime running within Tomcat. I’'ve tried specifying the IP address and the port.

SASL authentication failed:

at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java: 205)

at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:426)

at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:389)

at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:370)

Any thoughts? My Wildfire settings are all defaults.

Problem solved. I’'m slightly embarrassed to admit that it was an incorrect password.