Failed setup on Solaris 10 - Wildfire 3.1.1

Greetings -

I downloaded the cross-platform Wildfire 3.1.1 package to do some preliminary testing, but can’‘t seem to complete the setup. For my immediate purposes, I’'m attempting the simplest install possible, using the embedded DB. However, when I choose the “Default” location for user and group storage, I get a 500 Internal Server Error.

Process traces showed it looking for a SAXParserFactory class, which didn’'t seem to exist. So I grabbed the Apache xerces package to satisfy that (it seems odd that I would have to do that, no?). Anyway, I still get failures on setup.

Here’'s the exception from the admin-console.log:

11:34:07.400 WARN!! [SocketListener0-1] org.mortbay.jetty.servlet.ServletHandler.handle( >11> /setup/setup-profile-settings.jsp:


at org.jivesoftware.util.JiveGlobals.deleteXMLProperty(

at org.jivesoftware.wildfire.admin.setup.setup_002dprofile_002dsettings_jsp._jspSe rvice(

at org.apache.jasper.runtime.HttpJspBase.service(

at javax.servlet.http.HttpServlet.service(

at org.mortbay.jetty.servlet.ServletHolder.handle(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage( 8)

at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.jivesoftware.util.LocaleFilter.doFilter(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.jivesoftware.admin.PluginFilter.doFilter(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.jivesoftware.admin.AuthCheckFilter.doFilter(

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:471)

at org.mortbay.jetty.servlet.ServletHandler.handle(

at org.mortbay.http.HttpContext.handle(

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:633)

at org.mortbay.http.HttpContext.handle(

at org.mortbay.http.HttpServer.service(

If I choose the LDAP option instead, it seem to proceed OK, but I don’'t have a directory to use right now. I was hoping to avoid having to set up an LDAP server just for this test, but unless somebody has a gem of wisdom on this one, I guess I will have to resort to that.



Nevermind… I think I figured it out. It seems the supplied wildfire.xml that comes with the cross-platform package had trailing ^M characters on all the lines. I initially spotted this problem right away, and fixed it. The only problem is that the very last line of the file did not have this character, so my global replace inadvertently dropped the final > from the XML.

Setup works fine now, although for some reason, I need to run ‘‘wildfire start’’ as root… if I try as the jive user, it complains, evern though I’'ve chowned all the files to the jive user.

Any any rate, it’'s working.

Oh… one other nit to pick… why is the gzip’‘d tarballs of the distro boned up? The file is named “wildfire_3_1_1.tar.gz”, but in reality it’‘s gzip’‘d twice, so the filename would more accurately be “wildfire_3_1_1.tar.gz.gz”. Took me a minute to figure out why I couldn’'t untar it initially.