powered by Jive Software

Failed to create connection to remote server?

I keep seeing these errors in the debug log and all my clients are having sporadic issues of connecting and sending IM and chats.

java.lang.Exception: Failed to create connection to remote server

I’‘ve tried Exodus, Spark and Trillian and they all connect and get authorized to the server but can’‘t add clients because (at least I’‘m thinking) they can’'t see the other clients. The server is 2.3.0 on linux. Everything else seems fine, I can edit any and all settings in the admin console, the database is working fine. Not sure why I keep getting Failed to create connection to remote server.

Any ideas?

Thanks.

I got the same problem here… we have wildfire2.50 with soapbox2.5.

here’‘s one wildfire server1 over lan1 and server2 over lan2. there’'s already port 5269 open for both servers and the S2S config done.

Any hints will be appreciated.

Pete

Interpreting it in a very naive concept, have you got the two servers pinging to ensure that they recognize each other?

Have you tried switching it on?

Hi,

are both servers able to reach port 5269 of the other server? Are both servers able to resolve the IP address of the other server?

LG

Hi LG.

server1 @domain1 and server2 @domain2 are on different network and they oppened only tcp port 5269 for S2S. How can I test they communicate ok? I’‘ve tried from server1 telnet @domain2 5269 but I see nothing on the cmd prompt… I can’‘t ping the other server because they didn’'t open that tcp port. the DNS server did resolve both server names well.

thanks for your info.

Pete

at org.jivesoftware.wildfire.server.OutgoingServerSocketReader$1.run(OutgoingServe rSocketReader.java:91)

at org.dom4j.io.XMPPPacketReader.parseDocument(XMPPPacketReader.java:290)

at org.xmlpull.mxp1.MXParser.nextToken(MXParser.java:1100)

at org.jivesoftware.wildfire.net.MXParser.nextImpl(MXParser.java:75)

at org.xmlpull.mxp1.MXParser.more(MXParser.java:3025)

at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:2971)

at java.io.InputStreamReader.read(Unknown Source)

at sun.nio.cs.StreamDecoder.read(Unknown Source)

at sun.nio.cs.StreamDecoder$CharsetSD.implRead(Unknown Source)

at sun.nio.cs.StreamDecoder$CharsetSD.readBytes(Unknown Source)

at java.net.SocketInputStream.read(Unknown Source)

at java.net.SocketInputStream.socketRead0(Native Method)

java.net.SocketException: Socket closed

2006.05.05 01:33:39 Finishing Outgoing Server Reader. No session to close.

at java.lang.Thread.run(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:91)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$300(OutgoingSess ionPromise.java:37)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.createSessionAndSendPac ket(OutgoingSessionPromise.java:139)

java.lang.Exception: Failed to create connection to remote server

2006.05.05 01:33:39 Error sending packet to remote server:

2006.05.05 01:33:39 OS - Time out waiting for answer in validation from: jabber.org id: 233004554 for domain: sjobeck.com

2006.05.05 01:33:19 OS - Sent dialback key to host: jabber.org id: 233004554 from domain: sjobeck.com

2006.05.05 01:33:19 OS - Connection to jabber.org:5269 successful

2006.05.05 01:33:19 OS - Trying to connect to jabber.org:5269

2006.05.05 01:33:19 OS - Going to try connecting using server dialback

2006.05.05 01:33:19 OS - Plain connection to jabber.org:5269 successful

2006.05.05 01:33:19 OS - Trying to connect to jabber.org:5269

— Marker inserted by admin at May 5, 2006 1:32:29 AM —

I am having the same issue as the original poster. I am running the latest version of wildfire on SuSE 10 server.

This thread started out on a tangent topic here:

http://www.jivesoftware.org/community/message.jspa?messageID=120040#120040

but now it seems it has moved over a little bit, and is now more of a server-to-server issue.

I worry it is my external DNS records. I have since tweaked them a bit & queried them from outside from here:

and think I am on the correct path. I am not sure. My DNS vendor does not offer SRV records & I have gotten away with using TXT records on their nameservers for other services like SPF, so was hoping that they would work here too. If jabber and or XMPP do not like TXT, and or require SRV, then I’'m screwed.

Just for full disclosure, in case it matters, we split DNS internally and externally, and the internal DNS does not have the same TXT records. I am not thinking it is relevant though, since my jive server is talking to the server at jabber.org, so would be querying the zone file for jabber.org, not sjobeck.com, does that seem correct? I am not sure why our internal jive server would query the internal name servers for sjobeck.com records for this. If it is, I’'m in trouble, and have some work to do.

Any one else have any insight for me on this one?

Thanks very much.

Jason