Failing to install Spark 2.6.3

Sorry if this is already answered, I couldn’t find anything enough like it in the forum . . .

I have a fresh install of Windows 7, and Java SDK 6 update 26 (64-bit).

When attempting to install Spark 2.6.3 (and even 2.6.2) the installer complains that it can’t find a JRE.

I am using spark_2_6_3_online.exe dl from

Any java.exe that I point it to results in the same error:

The JVM found at is damaged.

Please reinstall or define EXE4J_JAVA_HOME to point to an installed JDK or JRE.


When I look at the logs (a few are attached), it seems to be checking for dlls in a variety of (unreasonably) specific locations, finding some, but not others (some of which do exist in those locations).

I tried defining EXE4J_JAVA_HOME to a few locations, but I guess it couldn’t help, since it thinks all my JREs are broken.

Any ideas/fixes would be greatly appreciated!

I really like Spark much better than all the other xmpp clients I’ve tried, so I’d love for this to be resolved

Thanks in advance,

Kazu (8269 Bytes)

Very similar problem.

Try the full installer. Probably Spark can’t run with the 64-bit java.

Yeah, same issue, thanks

I’d still prefer a fix to this workaround . . . I shouldn’t need to install a 32-bit JRE to supplement the already installed 64-bit one. Maybe I can just check out the src and build it manually, or something . . .

Sorry. Not a developer, can’t say whether it is possible.

I fixed this by uninstalling java from the control panel and reinstalling it fresh, but that was on a 32bit PC.