Failure installing openfire on windows server

I managed to install the server on an xp machine but on my main windows server i’m unable to install it. i know this discussion was posted earlier but since there was no solution, i’m trying to ‘reignite’ the interest on the topic.

when i run the file (22.6MB) downloaded from the openfire server, i manage to run it, choose install location, etc. but when it comes to actually installing, it fails with the following error message:

Error 592974390976343447 wrong magic number

i have to click OK and it stops installing. i tried reinstalling my java software but still no luck. reboot also done.

add: i have a feeling this is related to a follow up installation. I attempted to install the server version 3.6.0a and it worked fine and ran fine. then, in the process of upgrading, it uninstalled the server but failed (obviously). upon my reinstalling the 3.6.0a that too failed, with the same error message. now i can’t install. however, it seems to be running fine when i try to simply ‘run’ the server from the 7.x MB file (in the bin directory)