powered by Jive Software

[fastpath] Atendente nunca entrou (Agent never joined)

Olá,

estou tentando entender e reproduzir a mensagem “agent never joined” que é mostrada no “Resumo de Conversas”, ele ocorre poucas vezes para nós, mas preciso identificar quando isso acontece e porque.

alguém sabe algo sobre isso ?

att,

João.

Pode ser mais claro velho? Não consegui captar teu problema.

No Openfire** **instalamos um plugin chamado fastpath, ele traz algumas funcionalidades como relatório de conversas e o **status **de cada conversa. Há situações em que o status da conversa aparece como “Agent never joined”, mas não sabemos como reproduzir esse status. Já fiz vários testes com todas as possibilidades que conheço e não consigo reproduzi-la.

Preciso saber como reproduzir essa mensagem no relatório. Pelo que analisei acontece quando por algum motivo desconhecido a data de início da conversa não é gravada no banco de dados, dessa forma o Openfire trata de forma errada o status que deveria ser algum coisa como “erro desconhecido!” mas ele acaba contabilizando como “Agent never joined”.

cara não conheço muito bem p fastpath, porem precisei acredito que das mesma informações (log de resumo das conversas, e status dos usuarios), e comecei a utilizar o plugin monitoring service, que alem de ter todo o status das conversas como tempo de conversação horario iniciado e as frases trocadas ainda grava em banco de dados e exporta em PDF.

Sera que te ajuda em alguma coisa?

ajudou… não conhecia o ‘Monitoring Service’, lembro que uma vez era p/ implementarmos um relatório e cria-lo dps em PDF, mas como as conversar são gravadas em formato XML no banco daria muito trabalho pra fazer o parser e acabamos fazendo um relatório dentro do fastpash com JSP.

mas o problema aqui é que preciso saber como reproduzir a mensagem “agent never joined” que é mostrada no relatório do fastpath.

olá João

ainda não testei o fastpath. infelizmente não consigo te ajudar.

vou tentar instalar ainda esta semana e te aviso se conseguir alguma coisa.

como está a tua instalação? vc fez alguma configuração diferente do normal?

você tem algum passo-a-passo de quando dá o problema, em qual tela? ou é exatamente isso que vc está com problema…

té+

Hamilton

“… Não esqueça de fazer parte da nossa comunidade Brasil!”

Na verdade fiz algumas coisas fora do comum, gerei o Openfire a partir dos fontes, estou usando uma versão que traduzimos. O que estou tentando fazer é entender em que situação o relatório usa a mensagem “agent never joined”.

entendi

perguntei, prá ver se tinha algo de diferente mesmo

como falei, vou fazer alguns testes durante esta semana e te aviso…

té+

Hamilton

“… Não esqueça de fazer parte da nossa comunidade Brasil!”

Acredito que este problema deve ser resolvido por desenvolvedores João, pois o que voce esta procurando possivelmente seja uma rotina de tratamento de erro e não um evento casual ou duvida de utilização, publique este topico em ingles e acredito que sera resolvido.

Pois é, publiquei em inglês antes de publicar aqui, há gente com problema parecido e ninguém sabe ao certo.

P/ mim tem um erro de lógica mas não conheço o Openfire suficiente pra dar certeza, queria que alguém confirmasse. Assim poderia criar um patch e tratar esse problema.