powered by Jive Software

Fastpath doesn't load

I’ve upgraded Openfire to 3.7 but Fastpath plugin does not load anymore. I’ve uninstalled it and installed over again but it does not appear on the menu bar, only in the Installed Plugins.

Fastpath is still not compatible with 3.7.0. You should downgrade to 3.6.4 of Openfire.

Hi Wroot

Is there anyway around this, or has anyone managed to get this working?

1 Like

Nobody is actively working on this plugin.

Are you serious??? This is so unfair! hAHHAhAHHAhAHHahAHahHAHahH

So, if it’s gonna be that way, could you indicate me a open source software that could do the same thing for me?

1 Like

In this discussion http://community.igniterealtime.org/message/210932#210932 You said:

“To use it with Openfire 3.7.0, install Fastpath Service on the Plugins page in Admin Console, but you will have to use webchat plugin from here http://community.igniterealtime.org/message/210832#210832 (webchat.war file) as this is so far the only version of this plugin compatible with 3.7.0.”

You didn’t mentioned the uncompability of the Service plugin in this post.

1 Like

My bad I’ve must confused Service and Webchat parts in my mind. So the Service plugin is working. It is just that the Downloads page was recently broken and shows old plugins versions. Try uploading this (attached) via Plugins > Upload field.
fastpath 4.2.0.jar (416074 Bytes)

1 Like

Cheers for the wr00t.

I am still having some rather odd issues.

Running latest version of Fastpath 4.2.0 - Running the latest webchat.war on openfire 3.7.0

The Fastpath tab is now appearing, and I have uploaded the webchat.war onto apache-tomcat server

I am able to connect to the webcat plugin, however it does not display my workgroup images, and I am unable to connect to the workgroups.

I deployed the webchat to the plugins folder of my openfire directory and connceted via port 9090 and that appeared fine… So it must be a webserver issue?

Should I try and deploy to jetty?

Ok very strange…

Loaded in jetty and everthing appears to be fine now.

However when you create a fastpath group, you are unable to assign images to that group?

It just shows the following option -

Web UI Image Configuration

Update Images

All my other pre-created workgroups are showing fine.

Logs saying -

line
451
452
453
454
455
456
457
458
459
460
461
462
463
464
465
466
467
468
469
470
471
472
473
474
475
476
477
478
479
480
481
482
483
484
485
486
487
488
489
490
491
492
493
494
495
496
497
498
499
500
2011.08.08 11:11:33 web/images/end_button.gif (No such file or directory)
java.io.FileNotFoundException: web/images/end_button.gif (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.(Unknown Source)
at org.jivesoftware.openfire.fastpath.settings.chat.ChatSettingsCreator.createImag eSettings(ChatSettingsCreator.java:244)
at org.jivesoftware.openfire.fastpath.settings.chat.ChatSettingsCreator.createDefa ultSettings(ChatSettingsCreator.java:377)
at org.jivesoftware.openfire.fastpath.util.WorkgroupUtils.createWorkgroup(Workgrou pUtils.java:257)
at org.jivesoftware.openfire.plugin.fastpath.workgroup_002dcreate_jsp._jspService( workgroup_002dcreate_jsp.java:80)

Thank you, @wroot, for attaching the new plugin. It works for me! What needs to be done to fix the downloads page to get the new versions of the Fastpath Service and Fastpath Webchat plugins on there?

I had to bug someone to finally fix it and now it is fixed

1 Like

Cool - thank you, wroot! I see Fastpath Service 4.2 on there now. Can you also get Fastpath Webchat 4.0.2 on there?

I haven’t heard about the official release of Webchat 4.0.2. If it is unofficial, well, then we have to get enough positive comments on it. Can you point where exactly is this version (what thread and attachment).

It’s in the first message of the Updated sources for webchat - works with 3.7.0 discussion.

I have asked Daryl on that thread if we can add it to the plugins page.

1 Like

You need to enter ip address instead dns domain name, then you wil be able to see the image