powered by Jive Software

Fastpath 'Error creating connection to server'

Folks,

After installing Fastpath Service and Fastpath Webchat plug-ins (from OPF 3.6.2), I try to click ‘Test Settings’ the Dialog Box hangs, showing only a ‘Close’ button. Restarting OPF and trying again, I get various warn.log & error.log backtraces. I have not installed Spark or SparkWeb, but is that critical? Based on the guides, I thought the Fastpath Webchat plug-in should handle that. Also my XMPP.domain is set to (edited for posting purposes) ‘my-domain.com’, but the chat-server serverDomain is set to bea.test.my-domain.com. I have tried setting serverDomain to ‘my-domain.com’, but that has not helped.

Thanks,

BEA

[root@bea WEB-INF]# pwd
/opt/openfire/plugins/webchat/WEB-INF
[root@bea WEB-INF]# ls
chat-settings.xml dwr.xml lib taglibs-mailer.tld web.xml web.xml.generated
[root@bea WEB-INF]# cat chat-settings.xml

bea.test.my-domain.com
5222
false
-1

[root@bea WEB-INF]#

==> warn.log <==
2009.01.19 12:40:40 Error creating connection to server.
XMPPError connecting to bea.test.my-domain.com:5222.: remote-server-error(502) XMPPError connecting to bea.test.my-domain.com:5222.
– caused by: java.net.ConnectException: Connection refused
at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:806)
at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:1252)
at org.jivesoftware.webchat.ChatManager.createConnection(ChatManager.java:270)
at org.jivesoftware.webchat.FastpathServlet.init(FastpathServlet.java:111)
at org.mortbay.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:433)
at org.mortbay.jetty.servlet.ServletHolder.doStart(ServletHolder.java:256)
at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:39)

Nested Exception:
java.net.ConnectException: Connection refused
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.(Unknown Source)
at java.net.Socket.(Unknown Source)
at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:791)
at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:1252)
at org.jivesoftware.webchat.ChatManager.createConnection(ChatManager.java:270)
at org.jivesoftware.webchat.FastpathServlet.init(FastpathServlet.java:111)

When I access http://bea.test.my-domain.com:9090/webchat/, the output page says, ‘Unable to connect to server using the following settings’, as below. However, clicking the ‘Test Connection’ link results in a page that says ‘Server Connection Test Results: Connected!’. Any ideas? It looks like Fastpath is looking for a work group to join, but does not show the ‘workgroup-demo’ default.

Thanks

Fastpath Web Chat

List of available workgroups within Fastpath

Click on one of the following workgroups to join.

Unable to connect to server using the following settings:
Server: bea.test.my-domain.com
Port: 5222
SSL Enabled: false
Test Connection

Please change your server settings in the setup tool.

My set up was highly customized, using Hybrid-Auth, and external JDBC providers, which may conflict with Fastpath setup. After some more research, I have decided to start with a fresh Linux OS install and see how it goes.

“This problem is almost always a symptom of network issues of some kind.” *1

http://www.igniterealtime.org/community/docs/DOC-1280

Oh boy, discovered how vital Spark was to a functioning system. I was going along thinking that somehow Spark was not required, and striking out. Now that I have Spark installed, the Chat System is working (better). I still see Connection errors as described, but at least I can demo it to my group.

My group was very excited with the results. I set up a demo for them and they were thrilled, big thanks. One issue though is how can the docs be updated to reflect the latest builds/revs? Also I still see Java Exceptions in the webchat-error.log, even though it appears to be functioning properly. I am thinking it has been posted before, but if we could start a FAQ, that would be useful for others. If, for example, I go through source line debugging, and find the answer, I would like to share this knowledge in a logical place so that it can be found without necessarily relying on the forum or repeating the same exercise.

Discovered the solution after chatting on Open_Chat@IgniteRealtime.org two solutions that cleared up all error.log messages.

  1. Found that the server name (e.g. DNS hostname), Openfire XMPP.DOMAIN property, /opt/openfire/plugins/webchat/WEB-INF/chat-settings.xml value, and certs must match.

  2. Opening port access to 5269 on network node.

Updating this resolved the “Error trying to connect to remote server: test.mydomain.com(DNS lookup: test.mydomain.com:5269)”.

Notes:

Fastpath will still work if the XMPP.Domain is set differently, but trying to view workgroups via http://bea.test.mydomain.com:9090/webchat/ will not. This is due to the using the proper javascript settings in the Fastpath Snippet. I am looking at modifying Fastpath sources to allow a separate host setting.

Special thanks to Todd Getz for the clarifications.

Postmortem Note: Simple update to /etc/hosts, adding domain entry to resolve to local IP is also a working solution(!).

Updated Fastpath Webchat plugin here : http://www.igniterealtime.org/community/docs/DOC-1744