powered by Jive Software

Fastpath webchat - "Closing session due to incorrect hostname in stream"

When trying to use fastpath webchat on 3.2.2 I get the following message when going to lewis.shef.ac.uk:9090/webchat

2007.02.28 14:50:42 Closing session due to incorrect hostname in stream header. Host: lewis.shef.ac.uk. Connection: org.jivesoftware.wildfire.net.SocketConnection@794f13 socket: Socket[addr=/143.167.1.56,port=34977,localport=5269] session: null

2007.02.28 14:50:42 Closing session due to incorrect hostname in stream header. Host: shef.ac.uk. Connection: org.jivesoftware.wildfire.net.SocketConnection@13cb43e socket: Socket[addr=/143.167.1.56,port=34979,localport=5269] session: null

None of the workgroups appear in the webchat page.

Our xmpp domain is configured as sheffield.ac.uk, but the webchat stuff seems to be trying to connect to the server directly as “lewis.shef.ac.uk”.

Any ideas?

Cheers,

Andrew

Andrew, are you running the upgraded version of webchat? Also, are you running webchat within the wildfire admin console as a plugin or in a different server?

Hi Kevin, We’'re running the latest Enterprise plugin. Is that sufficient?

Cheers,

Andrew

I’'m telling fibs. I had upgraded the webchat plugin too.

I reinstalled the plugin and noticed during the setup section that it was asking for the server name. Rather than leave it with the hostname (which was already populated in the field) I put the XMPP domain in there.

Problem Solved! It works!

Cheers,

Andrew