powered by Jive Software

Fastpath webchat setup-index.jsp

Has anyone come across this error message when trying to set up fastpath?

HTTP ERROR: 500

INTERNAL_SERVER_ERROR

RequestURI=/webchat/setup-index.jsp

Caused by:

java.lang.NullPointerException
     at org.jivesoftware.webclient.jsp.setup_002dindex_jsp._jspService(setup_002dindex_jsp.java:76)
     at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
     at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
     at org.jivesoftware.webchat.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:45)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.webchat.SetupFilter.doFilter(SetupFilter.java:92)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
     at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
     at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
     at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
     at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
     at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
     at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
     at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
     at org.mortbay.jetty.Server.handle(Server.java:324)
     at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
     at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:843)
     at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)
     at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
     at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
     at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
     at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Essentially when you build webchat.jar from source, in the target directory is the interpreted .jsp file, which turns into a .java file. So this line turns out to be the connection, ‘con.loginAnonymously();’, which is failing. Is your Openfire set up to allow anonymous logins? See Server->Server Settings->Registration & Login->Anonymous Login.

HTH

[bea@foo ~/webchat/4_0_0]$ cat ./target/classes/jspc/java/org/jivesoftware/webclient/jsp/setup_002dindex_jsp.j ava

... 60     if (doSave) {^M 61         // Validate parameters^M 62         if (domain == null) {^M 63             errors.put("domain","The server domain is invalid.");^M 64         }^M 65         if (host == null) {^M 66             errors.put("host","The server host is invalid.");^M 67         }^M 68         if (port < 0) {^M 69             errors.put("port","Please specify a valid port.");^M 70         }^M 71 ^M 72         try {^M 73             ConnectionConfiguration xmppConfig = new ConnectionConfiguration(host, port, domain);^M 74             XMPPConnection con = new XMPPConnection(xmppConfig);^M 75             con.connect();^M 76             con.loginAnonymously();^M 77         }^M 78         catch (XMPPException xe) {^M 79             // If anonymous login disabled.^M 80             if (xe.getXMPPError().getCode() == 403) {^M 81                 errors.put("connect", "Anonymous login test failed. Ensure that anonymous logins are enabled on the server.");^M 82             }^M 83             else {^M 84                 errors.put("connect", "Could not connect to server. Please check that the domain and port are valid.");^M 85             }^M 86         }^M
...

Thanks for replying. I do have anonymous login enabled