powered by Jive Software

Fastpath

I noticed that fastpath only works work for a few minutes right after an openfire server service restart. If the client sits for a little while a customer from the web can’t connect to a agent. The icon says to click here for help and I have one agent logged in and it still doesn’t work. I can restart the server and it will work. Anybody else see this before?

Thanks,

Tim

I’m having the same problem. After a server restart it works once. After that if a customer clicks on the icon for help, they can log in the agent accepts the request and enters the room but the customer gets a message saying they could not be connected to an agent and the session ends. We need to resolve this before we make it live.

Any help is appreciated. Thanks

Here’s a log entry I found I think is related to the problem:

2008.02.01 23:03:11 Error creating connection to server.

No response from the server.:

at org.jivesoftware.smack.SASLAuthentication.bindResourceAndEstablishSession(SASLA uthentication.java:303)

at org.jivesoftware.smack.SASLAuthentication.authenticateAnonymously(SASLAuthentic ation.java:266)

at org.jivesoftware.smack.XMPPConnection.loginAnonymously(XMPPConnection.java:414)

at com.jivesoftware.webchat.ChatManager.createConnection(ChatManager.java:272)

at com.jivesoftware.webchat.FastpathServlet$1.run(FastpathServlet.java:117)

at java.util.TimerThread.mainLoop(Unknown Source)

at java.util.TimerThread.run(Unknown Source)

From that error message it looks like you’re using SASL security, could you try disabling it to see if that rights the issue?

How do I go about disabling SASL? Also I just realised that I’m running Openfire 3.4.3 with Enterprise 3.4.4 plugin, would this make a difference? I’m going to try upgrading tonite.

Yes the versions do make a difference. You need to be using the same version of both the plugin and server.

As for security, all of the security settings are in the admin console under ‘Server’->‘Security Settings’

I updated Openfire to 3.4.4 to match the enterprise plugin and also turned off SASL, still no luck. I do, however, have this entry in the error log now "2008.02.06 08:23:14 org.jivesoftware.openfire.ldap.LdapGroupProvider.getGroupNames(LdapGroupProvider .java:335) Could not find u

ser in LDAP aa6eff3b" So it looks like its trying to lookup customers in LDAP but it shouldn’t be.

After doing more searching through the forums I came across another post that relates to the problem I am having. It seems that because I was a Group Chat Admin that Fastpath would error out. I removed myself from the Admin and now it works. This is definitely a bug in my book.

Yes this definitely is a bug. It’s been reported and is currently in our issue tracking system. You can visit http://www.igniterealtime.org/issues/browse/ENT-286 for more information on this specific bug.

Cheers,

~Sean