Few problems running SparkWeb (OF 3.5.1)


I’ve downloaded SparkWeb from here : http://www.igniterealtime.org/community/docs/DOC-1515,

I’ve tried running it as a standalone SWF and as embedded in a web page and in both cases I had problems.

  1. As a standalone SWF: when I try to login, sometimes it logs me in directly with no problem and somtimes it rejects me saying “Not Authorized”. I’ve tried looking around the forum for some explanation to this, I didn’t find anything that corresponds to my problem (I am not using SSL btw, mostt of the people had problems with it).

  2. Embedded in a html page : I get a weird javascript error while I have no Js code in my page. “Error on line 48”, “Object Required”. My index.htm file is attached to the post, you can check it. This error happens on IE7 and not FF …

When I tried adding js code as explained here, http://www.igniterealtime.org/community/docs/DOC-1400 , it didn’t work and kept displaying that error I talked about previously.

Well i’m kind of confused because I have absolutely no clues, I am not a flash/flex developer, neither a jsp one, so I can’t check out the core code to debug it.

Auto logging users in my case is more than important since I’ll add Sparkweb in a dating website where users are already logged … I’ll have to manage chat requests via PHP and that’s another story I’ll talk about it later, along with some questions regarding Sparkweb interface customization.

Any idea ?
index.htm (1424 Bytes)

If you could get a trace of the network traffic when it fails that might shed some light on the situation.

Mine works.How I did mine was download sparkweb.zip unzip opent sparkweb.html and change servername to my openfire domain name then save the file as index.html then put srarkweb folder into the htdocs nave http://mydomainname/sparkweb/ and works every time.Now I have moved the sparkweb to my new apache tomcat and put in apps directory and it works grate there to


i’ve also tried the sample SparkWeb.html file, but it didn’t work everytime; most of the times the page loads, the orange background is visible but not the flash messenger. I have to refresh the page 2 or more times to get it working, and this happens on both IE7 and FF2 and randomly :s

I’ll try to post the network traffic …

Try gettin apache tomcat and running and see if theat workes better

Could this be due to the server ?

Actually I am running Aprelium Abyss 2.5 & php5.2, I never had any problem so far.

I have the same problem.I ran the SparkWeb as embedded in a web page,when I try to login ,sometimes it logs me indirectly with no problem ,and sometimes it rejects me saying"Not Authorized", I must refresh the page one or two times to get it working.

How to solve it?

didn’t find a way to log the network traffic, any idea how to do that? :s

anything new to this ? :s

Have you tried putting in the real web address or fully qualified domain name of the server instead of localhost?

I tried eveything :s

If you are using http-bind I do believe you need to use port 7070. You may want to try it without autologon first.

It doesn’t work if I use this :

which is quite normal, because my webserver runs on port 8000.

And this url as usual, displays the webpage with the orange backgound but doesn’t display the flash client.

I meant in your index.htm configuration file for the sparkweb. The index file needs to have the port set to 7070 like this:

function jive_sparkweb_getConfig()
return {
server: “localhost”,
port: “7070”,
//localtion: window.location.href,
bindPath: “/http-bind/”,
connectionType : “http”,
autologin: “true”,
username: “hbr”,
password: “123”
//policyFileURL: “http://www.example.com/sub/dir/crossdomain.xml
//policyFileURL: “xmlsocket://localhost:5229”


it looks like it is working now

thanks a lot m8, i’ll give it more tests and see!

Hello, -sorry for my english-

I have got a something else problem

I have got Windows Server 2003 StdEd SP1

I have installed WAMP5 1.7.2

I have donwloaded :Openfire 3.6.1

I have donwloaded : SparWeb 0.9.0

I put Sparwek directory into …\openfire\plugIns\admin\webapp\sparkweb

and into …\wamp\www\sparweb

I modified index.htm like this :

*function jive_sparkweb_getConfig()
return {
server: “localhost”,
port: “7070”,
//localtion: window.location.href,
bindPath: “/http-bind/”,
connectionType : “http”,
autologin: “false”,
//username: “admin”,
//password: “passwd”
//policyFileURL: “http://www.example.com/sub/dir/crossdomain.xml
//policyFileURL: “xmlsocket://localhost:5229”


All is ok when I open browser in the server. I can connect and chat. But into the server

.::. Login .::.

When I want do it in other place, in my computer for example, I have got only the login screen and nothing else other.

No warnning, no error in the server log.

.::. Create Account .::.

But when I want to acces with this URL and try to create account I have this warnning in the server :

  1. http://myserver.fr:9090/sparkweb/

  2. http://myserver.fr/sparkweb/

  3. http://myserver.fr/sparkweb/index.htm

2008.11.18 09:23:02 Closing session due to exception: (SOCKET, R: /, L: /, S:
org.apache.mina.filter.codec.ProtocolDecoderException: java.lang.Exception: Disallowed character (Hexdump: 3C 3F 78 6D 6C 20 76 65 72 73 69 6F 6E 3D 22 31 2E 30 22 3F 3E 3C 66 6C 61 73 68 3A 73 74 72 65 61 6D 20 74 6F 3D 22 76 61 72 2E 69 6E 74 65 67 2E 61 66 6E 6F 72 2E 66 72 22 20 78 6D 6C 6E 73 3D 22 6A 61 62 62 65 72 3A 63 6C 69 65 6E 74 22 20 78 6D 6C 6E 73 3A 66 6C 61 73 68 3D 22 68 74 74 70 3A 2F 2F 77 77 77 2E 6A 61 62 62 65 72 2E 63 6F 6D 2F 73 74 72 65 61 6D 73 2F 66 6C 61 73 68 22 20 76 65 72 73 69 6F 6E 3D 22 31 2E 30 22 20 2F 3E 00)
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF ilter.java:170)
at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(Ab stractIoFilterChain.java:299)
at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilt erChain.java:53)
at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceive d(AbstractIoFilterChain.java:648)
at org.apache.mina.filter.executor.ExecutorFilter.processEvent(ExecutorFilter.java :239)
at org.apache.mina.filter.executor.ExecutorFilter$ProcessEventsRunnable.run(Execut orFilter.java:283)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:51)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.Exception: Disallowed character
at org.jivesoftware.openfire.nio.XMLLightweightParser.read(XMLLightweightParser.ja va:210)
at org.jivesoftware.openfire.nio.XMPPDecoder.doDecode(XMPPDecoder.java:32)
at org.apache.mina.filter.codec.CumulativeProtocolDecoder.decode(CumulativeProtoco lDecoder.java:133)
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF ilter.java:163)
… 9 more

Other information :

I have got a problem with caracters. When I type ‘.’ it’s ‘:’ !?

Thank you for your help