Fields not specified (Users from LDAP)

Hello Community,

I have some problems. I set up an openfire Server with LDAP/ActiveDirectory access.

I tried MirandaPortable as test client. If I search for User with Username, the fields “Nick, First Name, Last Name and E-Mail” will shown with “not specified” in the search result. How can I declar them right? I tried server settings, the Advanced Settings at User Mapping, to customize them, but nothing happened :frowning:

Next Problem is, if I type something in the User-search-field in Miranda, he all time finds an User, can be “icurfbheonhvoeivj” and he finds the User, I want, that he only find Users, real existing in the Database, is this possible?

And at last, what is the “search service”? What is the Adress of thisservice and do I need it, cause I find all users without this “service”…

MANY THX for your help!!!


The default mappings that openfire uses are wrong and incomplete for AD. This is a nearly complete mapping:













{title} {wWWHomePage} {company} {department} ]]>


thx for your helping try…I edited my openfire.xml and insert your Code, but nothing changed :frowning:

Is there something to keep in mind?


The data needs to be complete with in their LDAP profile as well. If you have verified that the LDAP profile is complete and the vCard mapping is what I have provided then I would say it is an issue with miranda or what ever client you are using. I can verify that this does work correctly in spark. Additionally this is the default searchable fields in openfire: