powered by Jive Software

File transfer between spark clients does not work

Hello, I installed dedicated Wildfire 2.4.0 server ( connected to MS Server ).

Clients are Spark 1.0.2 on windows 2000.

Chating and conferences work great.

However when I try to send files, it gives me an error “File transfer was refused.”

Not important if the other person press accept or deny button.

The firewall was switched off during the testing.

I tried also to send from Spark to Exodus, after pressing accept in Exodus, Spark displayed “File transfer was refused”.

File transfer is important to me. Do you have any idea how to make it work ?

Thanks in advance

Hi crowndip,

To help me out, could you do the following:

  1. Start a chat with a user.

  2. Press F12. This brings up a traffic debugger.

  3. Try and send the file.

  4. Cut and paste the text from “Raw Sent Packets” and “Raw Received Packets”.

I will look into this asap. Sorry for the issue.

-Derek

Hello, here it is from the user that is trying to send the file:

Sent Raw Packets

Thank you

Hi crown,

Are both of you outside any firewall? Seems that the negotiating is just at the negotiation point.

Thanks,

Derek

What’‘s really unusual is the “-1” in the port for the file transfer initiation. This would seem to indicate, at least in my mind, that the initiaitor cannot establish a port to transfer on the local machine. I can only speculate as to what would cause this but it maybe a software based firewall on the initiator’'s machine.

crown: Are there any errors in your log file?

Alex

Hello,

Today I retried with switched off firewall and it works.

Yesterday i really tried several times with and without firewall.

With firewall, application on both ends simply waited and did nothing.

Without firewall, it said File transfer was refused.

I don’‘t understand it, but now it works so it’'s ok.

Maybe the application needed to be restarted …

btw. what ports do I need to have open on my firewall ?

Thanks to all for your great and fast support !!!