powered by Jive Software

File Transfer fails

Hello!

Since update to 3.2 I see the following behaviour when doing file transfer:

When a user tries to transfer a file, but the recepient does not accept (because not taking care for a minute or two) the transfer fails. BUT when the want to start over again TWO file transfer requests get transmitted and even when accepting this time, transfer will fail.

Also something gets screwed up, as ever further text im from the recepient to the sender gets bounced back twice and it looks like the other party simply typed the exact same IM twice. (? IM Echo!)

File transfer in the other direction does work perfectly! Both use Spark 2.0.8 but connect to the server from different subnets, the server is multihomed.

Hmm…

Bye

Starry

Hello!

Update:

Is it just me or is this a known fact?

When users keep on chatting when the file transfer is still negotiating (and not yet happening) it fails 100% here with Opfenfire 3.3.0 linux rpm with integrated db running rocksolid with just a couple of users so idling most of the time…

When both users shut up and let the negotiation happen it works most of the time at the second attempt. Almost never file transfer succeed at first try.

Clients are skinned 2.08, 2.5.3 and 2.54. The problem is independent of Spark version as far as I can see it.

Info: My server is dual homed so clients can be coming in via both NICs. However I did not see a difference, whether both clients are on the inner/outer side or half/half.

Thanks for looking into it…

Bye

Starry

Hello!

I guess I feel a little bit ignored, that there is nobody jumping on this one…

Bye

Starry

Hello!

Promised, this is my last attempt to get any attention towards this problem.

Cannot remember to have stepped on anbodys toes so there would be a reason to ignore me but you never know…

What’'s up IT2000, back in the old times you responded to each and every question within minutes, now dont you like the Austrians anymore?

Bye

Starry

Why are you still using 2.0.8?

We run 2.5.4 everywhere and we’‘ll be on the latest openfire after tonight, i’‘ll try get someone to help me test your theory… i can’‘t say i’'ve ever experienced that particular problem, but transfers do fail from time to time on our setup.

Message was edited by: ruxton