File Transfer Problem

Using 3.6.4 OpenFire with a Spark client using 3.5.8 and another using spark_2_6_0_12222, transferring files and screen shots does not work in the direction spark_2_6_0_12222 to 3.5.8, it does work in the direction 3.5.8 to spark_2_6_0_12222.

Should this mixed combination of software versions work or is this a bug ?

Is spark_2_6_0_12222 dependent on using OpenFire 3.7.0 ?

BTW when using Spark 3.5.8 everywhere we have not experianced any problem transfering files, even very big files of 100 meg or more, true this file transfer has been really slow but it does work.

Best Regards


There were lots of changes in the code (also in the file transfer code) so it is hard to maintain compatibility between versions. It should work ok between two RC2 versions and actually it should be much faster.

We expect all our users will move to 2.6.0 as soon as it is released, this combined with an upgrade to OpenFire 3.7 and all should be good again.

Thanks for the feedback.

The file transfer should not depend on the server or client version. If this is the case we have a major issue.

Is your OF server working in Proxy mode for file transfers?

Can not reproduce this behaviour after testing with OF 3.6.4 and Spark 2.5.8 against 2.6.0_12222

This is a risky assumption and might not be a working setup in the end. Let’s try to understand your issue before that.

Our OpenFire server 3.6.4 is configured to use file transfer proxy mode.

A little more testing produced the same result as before, however a new observation is that the problem only happens when the file transfer is to a computer running Win7 (32 or 64 bit) OS with Spark 2.5.8 installed.

Spark_2.6.0.12222 to Spark_2.6.0_12222 appears to work OK, as does sending files from any computer running 2.5.8 to a computer running Spark_2.6.0_12222.

Sending to a Win7 (32 or 64 bit) with Spark 2.5.8 installed from a computer running Spark_2.6.0_12222, the file transfer fails. The the client computers were not in the same location, all communication to and from the OpenFire server is via VPN.

This result has been replicated consistently and several times between several different combinations of computer / Spark.

Some of our colleagues in other locations, using the same OpenFire server, have been asked to try and replicate our test result. We will run these tests again tomorrow just to be sure we are not just missing the obvious.

Just a small correction. You always refer to older Spark version as 3.5.8. It is 2.5.8

As my old granny used to say when talking about software development… when at first you don’t see a bug you try and try but never see the damn bug …

I knew there was something wrong when writing these comments however I just could not see what it was, thanks.

We cloned our production OpenFire 3.6.4 server, upgraded the clone to OpenFire 3.7.0 and then tried the Spark RC file transfer again when connected to the 3.7.0 server.

The good news is that the file transfer worked OK, i.e. we have not been able to reproduce the file transfer problem when connected to OpenFire 3.7.0.

It appears that OpenFile 3.7.0 and Spark 2.6.x will be the way to go.