File transfer with proxy behind NAT


I’ve a problem about sending file with using openfire server as a proxy(on port 7777)

When I tried to connect and request the streamhost host address and port it returns something like that

however the host adress thats shown here ( is the local adress of the computer which openfire server runs.

However I’m not in that local area I’m reaching the server with a global ip adress and they nat(network adress translation) it to the local computer.

So as a result it becomes impossible to send the file to openfire server and it returns an error like below


I’ve checked the openfire server settings and the only setting about file transfer was the port number.I wasnt able to find any setting to set the ip of file server manually.

Does anyone know anything about this problem?


Create a patch for or wait until someone else does.

I’ve added the property xmpp.proxy.externalip to openfireserver with the value of external ip adress of my server.Then the returning streamhost property was changed with the external ip adress like below

but the service unavailable error is still exists and I’m still not able to transfer file

Is this issue still realated with OF-512 and if it is is there any fix for that**?****


The chat client should use the fall back method of IBB, if streaming fails. This decreases throughput, but allows file transfers. Spark nightlys are doing it.

Interesting property. Did you enable NAT also for the external IP:7777 ?

yes the nat is enabled in the foreground server side which is forwarding every request that is coming to 107.x.x.x to but even though I can get the external ip of the host adress I’m not able to transfer file and its giving the error(as I mentioned above)

walter ebeling: I didnt understand what you mean by The chat client should use the fall back method of IBB

can you explain it a little bit or can you show me an example url



The chat client should use the fall back method of IBB

I’m not connecting to openfire with ssl connection.I’m connecting to open fire with non SASL connection can it be the reason?

Thats the only thing that came to my mind?

I’ve finally make file transfer work.The reason for this error was I was not adding resource to jid of the receiving user

and also I have to add the xmpp.proxy.transfer.required to false to avoid 404 errors.

But I 've some other problems with file transfering.

My first problem is I want to send the file to server and server sends it to user but while doing it I want it to work like whatsapp application.I mean when I send the file through proxy , even if the target user is offline openfire server should store the file (for a certain amount of time) and then send the file as soon as target user is online.

Is something like that possible with openfire?