powered by Jive Software

File Transfering is Not working on Spark 2.8.2

I am using Spark 2.8.2 with Openfire 4.1.0

After I accept the file transfer it is showing “There was an error during file transfer” in the receiving side

and on the sending side “Negotiating file transfer with client,please wait…” .

Does any one got such issues ?

1 Like

It works fine for me with Openfire 4.0.4. I haven’t yet updated to 4.1 branch, so can’t test with it. Windows 7 Pro clients.

I tried with Openfire 4.0.4 but no luck. Is your Openfire is on Windows or Linux ?.

On Windows, but it doesn’t matter as i only have 5222 and 9091 ports allowed in firewall. I have File transfer proxy disabled in Admin Console. So Spark is not using Openfire for file transfer, it should be direct peer to peer in my case.

I just did that and it is not make any difference on the result.But my Old version of Spark 2.7.2 was working fine with file transfer with file transfer proxy enabled.

Spark 2.8 is using completely new Smack library (2.7 used 2-3 years old insecure Smack library). A lot has changed in Smack in those years, so some things are broken in Spark 2.8. File transfer is very complex thing (possibilities of network/routing setups are endless). And Spark doesn’t have competent developers to fix such issues. For me 2.7 also worked better with file transfers between different networks (e.g. in my virtual environment with different subnets). 2.8 works sometimes, sometimes doesn’t. Usually it works ok in the same subnet (like a local LAN). If you MUST have working file transfers, i suggest to use 2.7.7 version.

I can only file a ticket for this, but there is nobody to work on it. [SPARK-1869] Degraded file transfer feature when sending files between different networks - IgniteRealtime JIRA

yeah I noticed that I tried to use old smack libs then realize that many things are changed .so I am using the old code of spark 2.7.3. that works for me.

Thank you very much for your help.