powered by Jive Software

First login problem

HI, I’ve installed from .deb the latest openfire on my ubuntu box.

I’ve tryied both mysql db and embedded db bot with both I get an error trying to login after the first setup.

I’ve also changed pwd manually in mysql but can’t login to localhost:9090

How can I solve this? I’m starting to think that maybe the error isn’t in the user/pwd password but in the fact that admin user isn’t set as admin or moderator, how can I check this in mysql?

any other hint?

tks

Hi,

Did you try restarting Openfire ?

daryl

yes and I’ve redone the install process many times via deb or tar files trying to modify the mysql user record manually or via web wizard.

no way! same error every time.

error.log doesn’t prompt anything soI can’t go anywhere, pls help!

Hi,

you could try this (shutdown Openfire and append to openfire.script if you are using the embedded database):

INSERT INTO OFPROPERTY VALUES(‘admin.authorizedJIDs’,‘admin@your-xmpp-domain’)

LG

PS: “your-xmpp-domain” should match the ‘xmpp.domain’ value in OFPROPERTY, for the embedded-db it may look like this:

INSERT INTO OFUSER VALUES(‘admin’, ‘plain-text-password’,NULL, …

INSERT INTO OFPROPERTY VALUES(‘xmpp.domain’,‘example.com’)

INSERT INTO OFPROPERTY VALUES(‘admin.authorizedJIDs’,‘admin@example.com’)

it worked, I’m running on mysql but the insert step is the same.

Btw, what had happened that prevented me from the first login?

same problem on windows with embedded db, whare do I have to edit those files?

same problem to me on a W2k3

http://www.igniterealtime.org/community/thread/38418

Thats not a Help for me.

I thought ok, lets change the PW in the DB.

I could login after that. I could made different changes in the settings.

I checked in some users and had some chat sessions.

Now I restarted the machine an i cant login as admin, even I change the PW again.

No other user isnt able to loggin.