powered by Jive Software

Fresh Install of 3.8 on CentOS 6.3 Not Working

I’ve been working on this since last week, but for the life of me can’t get it to work. I have a newly installed copy of CentOS 6.3 that I installed OF 3.8 on, and I can’t get it up and running.

I installed the 32-bit libraries required, installed it using the RPM, ran the chown commands, but when I start the setup process I press ‘Test Settings’ and nothing happens. I’m using LDAP to connect to AD, by the way.

So, I figured it was working since it didn’t give me an error, and I continued, but when I get to the Add Administrator, it says ‘No username was provided or the specified username was not found.’ I’m using the exact same AD settings that I’m taking from a Windows-based server that’s working. I have disabled IPtables, so it’s not a firewall issue, and I can ping the domain controller.

Could it be a javascript problem? I’ve installed about everything I can think of.

I really want to move this off of the windows server, as it’s having stability issues, and I’m told that Linux-based is the way to go.

Thanks!

Scott

You might want to grab the RPM of the currently nightly and try again. I seem to recall that being a known issue, along with a bunch of other AD stuff.

OK, I’ll try that. Since these are not RPMs, how do I go about installing? I’m a linux noob.

Nevermind, I found it in the install document.

RPMs are here:

http://bamboo.igniterealtime.org/browse/OPENFIRE-NIGHTLYRPM-966/artifact/JOB1/Pr oject-RPM-installer-files/

Hmm. I tried it with the package manager, and was told that source packages aren’t installed this way, so I tried it via the command that’s listed in the install document. It ran, but I got errors saying that certain users didn’t exist, and that it was using root, but then nothing happened. The /opt/openfire folder isn’t there, and it didn’t try to download dependencies or anything. Is this a simple noob mistake I’m making?

Scott

If this doesn’t work, is there a way I can get the RPM of the 3.6.4 release? I can’t find old releases on the website anywhere.

I suppose you tried rpm and not the src.rpm? 3.6.4? maybe 3.7.1? You can download older versions by substituting version numbers in the download link. E.g. 3.6.4 - http://www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openf ire-3.6.4-1.i386.rpm

Heck yeah, I just clicked one and didn’t compare the two. So, I downloaded, installed and ran through the setup. No change. The ‘Test Settings’ button doesn’t do anything, and if I save and continue, when I get to adding admin accounts, it gives the same ‘no username was provided or the specified username was not found’ error. Grr…

Anything in the logs after you click test? Perhaps it can’t connect to AD or something?

That’s my thinking as well. I can ping the domain controller, and I have IPtables disabled. I also disabled the windows firewall.

I checked the warn.log, and have this message:

Unable to determine local hostname.

java.net.unknownhostexception: ACCOpenFire: ACCOpenFire

The error.log is empty.

Update: I’ve tried all the suggestions, but nothing seems to be helping. Not sure if there’s a problem with LDAP on the CentOS box, as there’s nothing in the Windows server log to show that it’s even hitting the active directory.

Have you set SELinux to Permissive mode?

do this:

vi /etc/selinux/config

Change:

SELINUX=enforcing

To:

SELINUX=permissive

You must now reboot to make it take full effect.

Uh oh…

/sysroot/etc/selinux/config: 11: permissive: not found

Kernel panic - not syncing: Attempted to kill init!

I’d start by fixing your DNS problem with your Linux system’s hostname. You could also enable LDAP debugging to see if you get better error information.

You can determine if you are talking to AD at all by running tcpdump and seeing if you see traffic on port 389 between the Linux system and AD.

We run Openfire with SELinux enabled - Since there are no pre-defined policies for Openfire with SELinux, it pretty much doesn’t care.

So, how do I fix the kernel panic?

Nevermind, I got it. I’ll have to figure out how to turn on the LDAP debug, and look at the tcpdump. I expect that LDAP isn’t working properly, although I still think there’s a javascript problem as well, which is why the ‘test settings’ button doesn’t work.

right but SELinux could be blocking something else…

also, isn’t SELinux the other way around? no policies then it blocks most things (in case it’s malicous in nature)?

a brand new install of CentOS should not kernel panic after changing SELinux policy… that could be another problem lol.

is this fresh hardware you isntalled on?

also, what happens when you do this from command line:

selinux=0

that should temp. disable it until reboot… the permissive settings leaves selinux on so it can log stuff, but not take action.

When troubleshooting things like this, i always disable selinux (permissive mode) first to make sure its’ not some weird case of selinux thinking it knows best… can’t tell you how many times i’ve banged my head on the wall only to find out its selinux blocking something… grrrr!!! shakes angry fist

also, have you installed the windows server plugin for UNIX compatibility? we run server 2003 for domain, so in newer versions it may be called something different, on mine I went to Add/remove windows components (from Add Remove Programs menu) --> Identity Management for UNIX

just a wild shot… :stuck_out_tongue_winking_eye: