Fresh Install - OF3.5.1/SQL/LDAP/AD - Can't login to Admin Console

I just got done installing and setting up OpenFire 3.5.1. Went through the setup wizard, set it up for my SQL server, setup LDAP, everything looks great. Added myself as an admin user, used the Test screen to put in my domain password and it said successful. I completed the setup wizard, click the button to login to the admin console, and it won’t take my username and password. I’m using my Domain username and password and it will not work. I have my username setup in the config file <authorizedUsernames> section and it still doesn’t work. I’ve even tried adding ‘admin’, because I saw in the sql database it created a user with the name admin and admin as password…i’m guessing this is a default…but even that doesn’t work. What am I doing wrong to be able to just login to the admin console?

Still hoping someone has some ideas. I’ve tried re-running through setup and still no dice…I don’t understand how this doesn’t work…I don’t know what else to try.

once you hook up an exterior authentication source, admin no longer works. have you looked in your logs to see if an error is being generated?

Yes, there are no log entries…the only thing I see is standard stuff in the info.log…and the thing is that I can login with my Spark client on my machine and it works…and I can search and find the other users in my AD group…it’s just that there’s more config I need to do in the Admin and it won’t let me login…for clarification, it says : Login failed: make sure your username and password are correct and that you’re an admin or moderator. Is there anything more I should be putting in the username box aside from my windows login name…it’s the same as how I set it up in the Setup wizard…AHHH.

so in these sections you have what?


<!-- Comma-delimitted list of bare JIDs. The JIDs may belong to local

or remote users. -->


can you post a copy of your openfire.xml (edited for security)?

This is what I’ve got. Now, obviously, “company” is replaced by my real domain name thats part of the AD.



I’m wondering how much I should be able to see with the LDAPDebugEnabled set to true…because I don’t see much of anything in either the openfire window or in any of the logs directory files.

I have attached a sample openfire.xml file for your reference.

Here’s my XML file…

<?xml version=“1.0” encoding=“UTF-8”?>

<!-- root element, all properties must be under this element -->



<!-- Disable either port by setting the value to -1 -->










<className>org.jivesoftware.database.DefaultConnectionProvider</classN ame>





<serverURL>jdbc:jtds:sqlserver://SERVER/OpenFire;appName=jive</serverU RL>



<testSQL>select 1</testSQL>












<adminDN>CN=Robert;OU=Technology;OU=Company Employees;DC=corp;DC=company;DC=com</adminDN>







<searchFilter>(memberOf=CN=Corporate List,CN=Users,DC=corp,DC=company,DC=com)</searchFilter>


<vCard xmlns=“vcard-temp”>













</ADR> <ADR>










</TEL> <TEL>
</TEL> <TEL>























<groupSearchFilter>(cn=Corporate List)</groupSearchFilter>




<className>org.jivesoftware.openfire.ldap.LdapVCardProvider</className >



<className>org.jivesoftware.openfire.ldap.LdapUserProvider</className& gt;



<className>org.jivesoftware.openfire.ldap.LdapAuthProvider</className& gt;



<className>org.jivesoftware.openfire.ldap.LdapGroupProvider</className >





I don’t know what to say…Everytime I tried loggin in, I used “Robert” with an upper case…just for the heck of it, I tried “robert” lowercase and it actually worked!!! WTF…that is just craziness, but i’m glad it finally worked. It’s working for me, but I don’t feel like it’s totally my fault for thinking that case on my username would matter?

that is sort of nuts… Glad to hear you found a solution, although it might create headaaches for you later…