powered by Jive Software

Frustrated with openfire support

I have tried several times to get some support from Jive but have gotten nowhere. I have called my Client Relationship Manager and also emailed them and still nothing. I can’t go live with openfire and I purchased it over 4 months ago due to fastpath errors I get. Can I please get some support on this. Here is the error I get but only every so often.

Jan 30, 2008 4:32:55 PM com.jivesoftware.webchat.util.WebLog logError

WARNING: Unable to login anonymously

Connection failed. No response from server.:

at org.jivesoftware.smack.PacketReader.startup(PacketReader.java:170)

at org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:851)

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:810)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:1252)

at com.jivesoftware.webchat.ChatSession.connect(ChatSession.java:122)

at com.jivesoftware.webchat.ChatSession.loginAnonymously(ChatSession.java:187)

at com.jivesoftware.webchat.actions.ChatStarter.startSession(ChatStarter.java:222)

at com.jivesoftware.webclient.jsp.queue_jsp._jspService(queue_jsp.java:75)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)

at com.jivesoftware.webchat.SetCharacterEncodingFilter.doFilter(SetCharacterEncodi ngFilter.java:44)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at com.jivesoftware.webchat.SetupFilter.doFilter(SetupFilter.java:91)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:324)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)

at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:842 )

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)

Jan 30, 2008 4:33:10 PM com.jivesoftware.webchat.util.WebLog logError

WARNING: Unable to login anonymously

Connection failed. No response from server.:

at org.jivesoftware.smack.PacketReader.startup(PacketReader.java:170)

at org.jivesoftware.smack.XMPPConnection.initConnection(XMPPConnection.java:851)

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:810)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:1252)

at com.jivesoftware.webchat.ChatSession.connect(ChatSession.java:122)

at com.jivesoftware.webchat.ChatSession.loginAnonymously(ChatSession.java:187)

at com.jivesoftware.webchat.actions.ChatStarter.startSession(ChatStarter.java:222)

at com.jivesoftware.webclient.jsp.queue_jsp._jspService(queue_jsp.java:75)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)

at com.jivesoftware.webchat.SetCharacterEncodingFilter.doFilter(SetCharacterEncodi ngFilter.java:44)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at com.jivesoftware.webchat.SetupFilter.doFilter(SetupFilter.java:91)

at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)

at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)

at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)

at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)

at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)

at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)

at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)

at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)

at org.mortbay.jetty.Server.handle(Server.java:324)

at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)

at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:842 )

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)

I have anonymous login enabled

Thanks,

Tim

Hi Tim,

I’m sorry for your frustration in receiving support. I’m not sure how you were trying to contact us before, but the proper way to engage us is to send an email to us here at support (at) jivesoftware dot com when you have a support contract with us; I have checked your companies record, and you do.

As for the error you are encountering: You say that this is only happening every once and a while, does this mean that fastpath works most of the time? Do you have a firewall in your network that could be causing issues?

Also, which version are you running?

Thank you for your response. Fastpath seems to not work more than it works. I can get in to an agent one time and then when that agent frees up and I try again it just sits there and says the service isn’t available.

We are running 3.4.4 and there isn’t any firewalls that it crosses at this point in testing.

Hi,

I have mocked this up locally, and my tests were all successful.

Are you using Enterprise v3.4.4 as well?

My steps:

  1. Log in as agent

  2. Use webchat to start a session

  3. Chat back and forth couple of times

  4. End session

  5. Use webchat to start another session

  6. No problems seen

Do your steps differ from mine at all?

That’s exactly what I do as well. I am running 3.4.4. It looks like to me that fastpath is trying to authenticate the webuser against active directory even though I don’t have the check in the box for that option.

Hi Tim,

It’s my understanding that another support engineer helped you out with this problem. The root causes of the issue were incorrect srv records and server name usage.