Gaim 2.0 with wildfire

I have been using wildfire for a while with gaim. I upgraded gaim to 2.0 (came with fedora core 6). Now I cannot connect to wildfire. I can connect to google talk and other jabber servers and I can connect to wildfire using other clients. It actually causes gaim to crash. Other people have posted to the gaim site with the same issue (wildfire issue).

I understand that gaim 2.0 is beta and it is most likely a gaim problem I just thought I would post here and see if anyone else is having similar issues.

All my users that have upgraded to gaim 2.0 are having the same issue.

By the way… I am using wildfire 3.1.1

gaim 2.0 has removed the TSL configuration form the Advanced tab. I think this may have something to do with it.


The same problem i have meet ,waiting for the answer

I have similar problems with gaim and wilfire

anybody have a solution on this?

I’'ve been using Gaim 2.0beta for quite a while … and it works fine with Wildfire (3.1 and 3.2RC).

What kind of error are you seeing?


Hey johnh,

I tested both with Gaim 1.5 and Gaim 2.0 beta 6 and both can connect to my account in Try connecting to that server and let us know how it worked.


– Gato

Could this be something to do with SSL?

Gaim 2.0 is using TLS when connected to I would recommend testing against and see if you are still having that problem. If it works then try connecting to your local server with no TLS and see if that works. If that is the case then it could be that a RSA cert is needed and you only have a DSA cert (or vice versa).


– Gato

Do you know how to debug with Gaim? If you can get a backtrace from gdb that would be helpful. Ive run into this with Gaim 2.0 betas- it is not SSL, but the new SASL stuff they put in. For me, whenever the server and client agree to use CRAM-MD5 Gaim pukes, and the backtrace leads it into the cyrus sasl libraries.

Yesterday I tested gaim using my Wildfire 3.1 server, and it worked fine. I’'m using TLS on port 5222 with the XMPP Foundation cert.

I tried to connect to and it only says Not Authorized so seems to work fine.

The weird thing is that I can connect with Spark and Adium client, only gaim is say “SSL Handshake Failed”. Is there any other changes on the server I can look into?


It works fine with on Ubuntu with self compiled Gaim 2 beta6,

here is my ./configure line

*./configure --prefix=/usr --enable-dbus --with-gnu-ld --disable-tcl --enable-gnutls=yes \

–disable-tk --disable-gevolution --disable-doxygen --disable-fortify --enable-cyrus-sasl