powered by Jive Software

GAIM always hangs on disconnect with Wildfire 2.4.0

I upgraded my server from Messenger 2.1.5 (I know… old!) to Wildfire 2.4.0 this past weekend. Because most of my users use GAIM, I had to disable the idle timeout.

Now when I log in with GAIM (1.5.1cvs from Debian GNU/Linux testing) it works fine, BUT, when I select Signoff from the GAIM menu GAIM just hangs, hard (by that I mean that the windows are there but they are not updated anymore: if I switch to another desktop or page and switch back, there’'s just a blank window there.

Also, I’‘ve checked the server and I my session is still active, so whatever happened the session disconnect didn’'t complete.

If I kill the window (with the title bar button or whatever) then it goes away and I can log in again.

Also, if I select the (X) button on the User Sessions screen of the Wildfire admin site to delete the connection on the server side, then my local GAIM comes back alive again and is successfully disconnected, giving me a login screen again.

It does NOT seem to matter how long I wait (in fact I left one in the hung state at home and when I got back from work hours later it was still hung).

To be clear, this behavior just started with the new Wildfire server and didn’‘t happen with the old Messenger server, and I’‘ve not updated GAIM. Most other people use older versions of GAIM and I haven’‘t heard anyone complain but most people don’'t disconnect very often so they just might not have noticed, or not been energized enough to let me know about it.

Thought?

No one has any love for me here? BTW, I tried it with GAIM 1.5.0 from Debian and that had the same hanging behavior… Does anyone else see this with GAIM?

I asked for others’’ experiences and I just got a report back that GAIM 1.3 doesn’'t have this problem… hm…

OK, more good stuff info. I tried another build of GAIM 1.5.0 and that one worked. On a hunch I checked and one difference between them is the one that hangs connects using SASL or TLS (not sure which: it’‘s the default secure connection because I didn’'t change anything in my account) and the one that works is not using secure connections.

Actually, to be clear: when I view my connection that hangs from the Wildfire server “Sessions” screen in the admin web pages, I see a lock icon next to it indicating a secure connection.

When I view my connection that works from that screen, there’'s no lock icon next to it.

Just a “me too” post, but we have a few users with the same problem. Gaim 1.5.0 on Suse Pro-9.3 hangs on disconnect. We tried the above suggestion and unchecked the “Use TLS” flag and no problems with disconnect. So workaround for now, but would like to find a better fix that would allow us to keep TLS in the mix.

Yah, I’‘ve been meaning to come back and bump this thread. Since I posted originally we upgraded to Wildfire 2.4.4 and still see this issue… don’‘t know if it’'s a GAIM bug or a Wildfire bug but I sure would appreciate it if someone could look into it…