GAIM connection problems


I am running Wildfire Enterprise 3.1.1 on FC5. My users authenticate to the server through Open LDAP. I am able to connect to the server using Spark finely, but the moment I start to experiment with any other clients, wildfire stops working properly. For example, when I used Gaim, I ran into the following errors. (I also tried to use Psi and Kopete, but I got similar errors using these clients as well).

Originally, I required my users to use secured connection to authenticate to the server. In the setup of the account on Gaim, I made sure to enable “Use TLS if available” option and connect to the server using port 5222. In responce, Gaim gave me an error that server does not use any supported authentication method, and the debug logs were as follows:

2007.02.02 15:49:09 Error delivering packet socket: Socket[addr=/,port=40574,localport=5222] session: org.jivesoftware.wildfire.ClientSession@1ae9565 status: 1 address: id: b98a18de presence: Socket closed
at Source)
at Source)
at java.nio.channels.Channels$WritableByteChannelImpl.write(Unknown Source)
at a:93)
at$100( 8)
at sun.nio.cs.StreamEncoder$CharsetSE.writeBytes(Unknown Source)
at sun.nio.cs.StreamEncoder$CharsetSE.implFlushBuffer(Unknown Source)
at sun.nio.cs.StreamEncoder$CharsetSE.implFlush(Unknown Source)
at sun.nio.cs.StreamEncoder.flush(Unknown Source)
at Source)
at Source)
at org.jivesoftware.util.XMLWriter.flush(
at 8)
at org.jivesoftware.wildfire.ClientSession.deliver(
at org.jivesoftware.wildfire.ClientSession.process(
at org.jivesoftware.wildfire.PresenceRouter.route(
at org.jivesoftware.wildfire.spi.PacketRouterImpl.route(
at 9)
at 62)
at Source)
2007.02.02 15:49:09 Logging off on socket: Socket[addr=/,port=40574,localport=5222] session: org.jivesoftware.wildfire.ClientSession@1ae9565 status: -1 address: id: b98a18de presence:

When I tried to enable “allow plaintext authentication over unencrypted streams”, I got the same error.

I thought that maybe the problem persists because I am using out-of-box certificates. Then I decided to disable secure connections and see what is going to happen. I made both TSL and old SSL methods unavailable. However, I left “Use TSL if available” box still checked at the account setup on Gaim. The error persisted, and the debug logs were as follows:

2007.02.02 15:55:09 Connect Socket[addr=/,port=32861,localport=5222]
2007.02.02 15:55:09 Logging off on socket: Socket[addr=/,port=32861,localport=5222] session: org.jivesoftware.wildfire.ClientSession@d68b39 status: 1 address: id: 7bcb2c3b presence:

Unchecking “Use TSL if available” box produced the same results as well.

I do not know what to do now. If I am not going to be able to login to the server using various clients, I guess I will have to choose a different client. I hope I will not have to do that and somebody here will be able to help me figure this out.

Thanks a lot,


What version of Java are you running with on the server?

Another thing to try, is in Gaim, turn on the debugging window before you connect. See if anything interesting shows up in the actual session. My guess is (at least with Gaim) that Gaim may not be issuing a starttls command, and thus the server dosnt give any sasl mechanisims that will work. But without seeing the conversation its hard to say.

I just had another thought. Go to the admin console, under the Enterprise tab, and select Permitted Clients. What settings do you have here?