[GENTOO] Problems accessing Webadmin 3.6.0

(I’m french)

Hi there!

i want to set up an openfire server on a Gentoo linux x64 2006.1 (OVH hosting).

I emerge JDK (1.6.0 | OK)

I emerge openfire (OK)

I start /etc/ini.d/openfire (seems to be OK)

I’ve no graphical interface on my server (only SSH/telnet) so i must access to web admin by internet. But I got no answer from 9090 (http) or 9091 (https)…

I’ve generated config.xml (/opt/openfire/config).

When i do nmap, 9090 is “open” (9090/tcp open zeus-admin) on both local IP and wan IP.

What i’ve done wrong??

PS: I’ve used search on forums but no answer concerning gentoo.

I don’t use Gentoo myself but CentOS - is the firewall enabled ? If so, have you allowed access through those ports ?

ks361908 ~ # iptables --list

Chain INPUT (policy ACCEPT)

target prot opt source destination

Chain FORWARD (policy ACCEPT)

target prot opt source destination

Chain OUTPUT (policy ACCEPT)

target prot opt source destination

IPTABLES Firewall has no rules: All allow. So i think FW is not the problem…

When i look at start log, it’s say that is listen to,

ks361908 logs # cat info.log

2008.09.12 13:50:58 Openfire 3.5.0 [12 sept. 2008 13:50:58]

2008.09.12 13:51:12 Console d’administration en écoute sur

2008.09.12 13:57:30 Server halted

2008.09.12 13:59:12 Openfire 3.5.0 [12 sept. 2008 13:59:12]

2008.09.12 13:59:15 Console d’administration en écoute sur

2008.09.12 14:34:26 Server halted

2008.09.12 14:37:59 Openfire 3.5.0 [12 sept. 2008 14:37:58]

2008.09.12 14:38:09 Console d’administration en écoute sur

(oh i just see that i’m not on 3.6.0 but 3.5.0… Will try to upgrade)


It works. I don’t know what i’ve done but it works! (iptables is disabled)

Now i’m configuring openfire with MySQL. I’ve created the DB but he said “connection refused” during step 3 (please read error.log, which is almost only java error messages).

But other problem, other question, i close this one.

OK, a step in the right direction.

When you installed MySQL, did you carry out any further admin ? Have you permitted the default user mysql access to the DB or created another user ?

You may need to go into /usr/bin (on RedHat variants) dir and execute mysql then grant permissions to the correct table for the user you created. Bear in mind permissions are also host centric unless you grant it from either a specific host or any host (not secure)

It’s something like (though I suggest you verify this !)



mysql>grant all on to identified by ‘’@% for any host or an IP or resolvable hostname. followed by ;




I’ve already excute this SQL command. Problem is stille the same. I also can’t connect to embedded DB.

No matter because i’ve tryed Ejabberd, and it works fine.

Thanks for the help

No worries - if you can’t access the internal DB then that sounds like a permissions problem. You may want to make sure that the Openfire daemon has permissions into the dir structrure including files.