powered by Jive Software

Going from LDAP to local..... Unable to log in

Hi all,

We are currently runing openfire using LDAP and Mysql.

I have attempted to run the setup again and then login as local admin, but no matter what, the login fails.

I have tried resetting the admin password in the DB with no luck.

Tried this about 8 time sbefore giving up and restoring from backup.

Can anyone shed some light on what I may be missing?

Thank you!

Hello

stop the openfire service

edit the openfire.xml

change the line

true

to

false

save and start the openfire servisce

in the browser enter the ip: 9090 and should start the Setup Wizard, follow the instructions.

on the last page add LDAP users will be administrators

I hope to be helpful

I run into 2 scenarios when I do that.

It either gets to the page where it asks to seup the amdin password, but it asks for the old one none of which work, or it lets me set is but when I do it wouldnt let me log in.

Just to confirm, I an using “admin” ad the username.

Not sure what you mean by “on the last page add LDAP users will be administrators”.

Thank you!

In the Wizzard, on the paga “Server Settings” is very important the Domain field: this should be equal to the ldap domain “my.domain.local”

Im confused,

Why would I be giving domain settings if im moving AWAY from LDAP to local?

Sorry, my English is not very good,

before leaving the ldap should have created a local user and add it to admin.authorizedJIDs to use it later.

Can you try Setup Wizard on page and “Profile Settings” select Default

Im still on LDAP.

When I go to create user I get: Not allowed: the user account system is read-only.