powered by Jive Software

Google Chat Call Back Failing

I’‘m trying to get our Wildfire server linked up with Gmail. There doesn’‘t seem like a whole lot to do setup wise, but nonetheless it’'s failing to stay up.

My setup is as following:

Jabber server: chat.mycompany-corp.com

int. dns resolves to: 10.x.x.x

ext dns resolved to: 65.x.x.x

Firewall maps the 65.x address to 10.x address on port 6529. The Jabber server can go out anywere, any port. (For now.)

With spark, logged into my jabber server, I’'m sending a chat to myuser@gmail.com and below is the log from the debug session. The connectivity seems fine, but something is causing the call back key to be invalid.

Thanks for your help inadvance.

Iota

2006.02.14 16:23:48 OS - Trying to connect to gmail.com:5269

2006.02.14 16:23:48 OS - Plain connection to gmail.com:5269 successful

2006.02.14 16:23:48 OS - Going to try connecting using server dialback

2006.02.14 16:23:48 OS - Trying to connect to gmail.com:5269

2006.02.14 16:23:48 OS - Connection to gmail.com:5269 successful

2006.02.14 16:23:48 OS - Sent dialback key to host: gmail.com id: A1143F170D126038 from domain: chat.mycompany-corp.com

2006.02.14 16:23:48 OS - Validation FAILED from: gmail.com id: A1143F170D126038 for domain: chat.mycompany-corp.com

2006.02.14 16:23:48 Finishing Outgoing Server Reader. No session to close.

java.net.SocketException: socket closed

at java.net.SocketInputStream.socketRead0(Native Method)

at java.net.SocketInputStream.read(Unknown Source)

at sun.nio.cs.StreamDecoder$CharsetSD.readBytes(Unknown Source)

at sun.nio.cs.StreamDecoder$CharsetSD.implRead(Unknown Source)

at sun.nio.cs.StreamDecoder.read(Unknown Source)

at java.io.InputStreamReader.read(Unknown Source)

at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:2971)

at org.xmlpull.mxp1.MXParser.more(MXParser.java:3025)

at org.jivesoftware.wildfire.net.MXParser.nextImpl(MXParser.java:75)

at org.xmlpull.mxp1.MXParser.nextToken(MXParser.java:1100)

at org.dom4j.io.XMPPPacketReader.parseDocument(XMPPPacketReader.java:290)

at org.jivesoftware.wildfire.server.OutgoingServerSocketReader$1.run(OutgoingServe rSocketReader.java:91)

2006.02.14 16:23:48 Error sending packet to remote server:

java.lang.Exception: Failed to create connection to remote server

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.createSessionAndSendPac ket(OutgoingSessionPromise.java:139)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$300(OutgoingSess ionPromise.java:37)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:91)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Hey Iota,

It seems that gmail (as any other remote server) is not being able to establish a connection back to your server on port 5269. When you said “Firewall maps the 65.x address to 10.x address on port 6529”. Did you want to say port 5269? If you are in fact using port 6529 then that’'s the problem since port 5269 must be used for server-2-server communication.

A quick way to test if you firewall is correctly configured is to try from a remote machine (outside of your net) to telnet to your server on port 5269. Something like telnet chat.mycompany-corp.com 5269 and see if that works. To be more accurate in the test you would need to run a DNS lookup first to get the real address of chat.mycompany-corp.com and then perform the telnet to that address.

Hope that helps.

Regards,

– Gato

Sorry… I meant to say 5269… and I have verified that the port answers from the outside world.

Well… it appears, without changing anything that it’'s working. The only thing I can think of is that I recently changed the name of the server in Wildfire and somehow, somehwere, something was cached. After a few hours (hrs only b/c I was busy) it appears to have fixed it self without rebooting the physical server. (I tried restarting wildfire many times).