Groups Dissapear after restart


I am new to Openfire (and Linux, MySql etc).

I set up in a Virtual Machine an Ubuntu server 14.4.3 64bit, with Openfire 3.10.2, using a MySQL 5.5.46-0 DB configured for utf8 support.

Database Connection Info
Database and Version:
MySQL 5.5.46-0ubuntu0.14.04.2
JDBC Driver:
MySQL Connector Java
JDBC Driver Version:
mysql-connector-java-5.1.30 ( Revision: )
DB Connection URL:
jdbc:mysql://localhost:3306/openfire?useUnicode=true&characterEncoding=UTF-8&ch aracterSetResults=UTF-8
DB User:
Transaction Support:
Transaction Isolation Level:
Supports multiple connections
open at once:
In read-only mode:

Yesterday I added manually the users and groups (all the names were in Greek). No LDAP or AD.

It worked well. I even locally connected a few users and saw the shared group that I had setup.

I turned off for the night my development pc and in the morning the users were still there, but the groups had disappeared.

The count said TOTAL GROUPS 14 but I could not see any. Also the users were not into the groups I assigned them in.

I added the group again. With each group I added, one old appeared as well but instead of name it had ??? ??? question marks.

Changing the encoding in the browser did not help to resolve the question marks. And after a few minutes the new groups disappeared again.

One group in particular called “test” but in Greek (τεστ) I could not create again as it reported it existing, but of course it was not visible.

Stopping and restarting the service for mysql and openfire did not help. Changing browser did not help either (from firefox to edge).

I feel that maybe it is an issue with the mysql encoding and the Greek names of the groups but I have no experience to pinpoint it.

Please help (considering my limited experience with all the involved systems, please answer as if you are talking to a child or an idiot - thank you in advance).


I think I fixed it.

It seems I had set some of the database encoding to utf8 but not all. Some remained to latin1.

I did the following to solve this:

I added to configuration file /etc/mysql/my.cnf the following lines

[mysqld] collation-server = utf8_unicode_ci init-connect='SET NAMES utf8' character-set-server = utf8

I then restarted the service and the groups appeared back in their place with their connections to the users again intact.