GTalk won't fetch openfire status

Hi,

First of all congratulations on OpenFire. I am very happy with your software and everything is working great axcept for one thing:

Let me explain. I have installed OpenFire server and I have created a user for myself on the OpenFire server. I use pidgin on linux to login with my OpenFire user. A friend with a GoogleTalk account has added my openfire user succesfully to his account and we have both auhorized each other. We can chat with no problem. However when he logs out and logs back in, he then sees me as offline even though I am online. What could be the cause of this?

I am using Openfire 3.7.0. on CentOS release 5.6 (Final).

Thanks again for your great work!,

Ludovic

okay maybe this is an issue with google talk. When my friend uses gmail with his browser, he always sees my status fine… Someone please confirm this.

I have tried many scenarios logging on and off on both Spark 2.6.3 (logged into igniterealtime.org Openfire server, which is 3.7.0 or even newer svn build) and Gtalk 1.0.0.104 Beta. Gtalk always shows the correct status of Spark user for me.

Thanks for the reply. I tried Spark 2.6.3 and I still have the same problem except now, I don’t see the status of my friend using GTalk. Again everything works fine when he uses the gmail web interface.

It should be noted the Openfire server is behind a NAT. Ports 5269 TCP/UDP, 5222 TCP/UDP and 7777 TCP/UDP are being forwarded to the server. Do I need to forward other ports? I have also added SRV records to my dns server. As for the certificates, I am using self signed certificates.

I have monitored the Last Activity field of the server session with gmail and there is activity when the GTalk user logs in or out and when he changes status. Only he doesn’t see my status, unless I initiate a status change with Spark, in which case he will then see my status. But when he logs out and then back in, he doesn’t see my status anymore, even though there is activity detected by the openfire server. I do not have any Error, Warning or Info logs. Just some debugging log which doesn’t seem pertinent to me. (see attachment)
openfirelog.txt.zip (4042 Bytes)