powered by Jive Software

Hazelcast tcp based cluster stopped working after upgrade from 3.8.2 to 3.9.3

Hi,

I just upgraded Openfire from 3.8.2 to 3.9.3, then upgraded all plugins. After server restart, the cluster stoped working - all nodes now see only themself. I tried many tweaks and spend about a day trying to make it work again, but without success.

I just have 2 nodes on 2 computers, there is no firewall between them.

The configuration is simple:

<hazelcast xsi:schemaLocation=“http://www.hazelcast.com/schema/config hazelcast-config-3.1.xsd”

       xmlns="[http://www.hazelcast.com/schema/config](http://www.hazelcast.com/schema/config)"

       xmlns:xsi="[http://www.w3.org/2001/XMLSchema-instance](http://www.w3.org/2001/XMLSchema-instance)">

openfire

openfire

5701

224.2.2.3

54327

192.168.129.79

192.168.162.197

Is there anybody to whom is tcp based configuration with Hazelcast in 3.9.3 working?

Thanks,

Jindrich

Jindrich -

I won’t be much help to the above but I do want to let you know that I have been having the same issues. I also know that on 3.92 and 3.93 the certifcate upload does not work for openfire. So you can’t use a CA sgined certifcate you can only generate self signed one. For this reason I dropped down to 3.91 and found out you could upload certifcates (on 3.91) and then I tried to configure clustering. I am having the same issue as you both servers only seeing them self. I also tried adding in the interfaces as some people said that might help but it did not for me. I’m getting ready to reach out on linkedin to the creator of the hazel cast plugin. I did find him but did not want to bother him unless needed.

What version of hazelcast were you using with 3.82. The latest version of hazelcast is not compatible with 3.82. If you still have the file for the old hazel cast plugin I would really like to get that from you. I can’t find it on the web and if I can’t have H/A in 3.91 then I am going to have to go down versions.

Long story short: I think the problem is present in any 3.9.X version.

P.S If I get the soultion… I will update this post.

1 Like

I am successfully using a TCP-based clustering configuration. One slight difference I see is that in my configuration I have included the clustering port number in the member element:

192.168.129.79:5701

192.168.162.197:5701

Give that a try … hope it helps.

Hi Tom,

thanks, but this is one of many things I already tried and it didn’t help.

Jindrich

Tom -

Thanks for the reply but that dident work either. Have you sucessfully used your hazelcast plugin with 3.91 or newer?

Jindrich -

Can you post a copy of what your working configeration file looked like on 3.8.2 please!

Thanks!