powered by Jive Software

Helga (a Server-Bot plugin)


#41

Just to clarify: You don’t have to use an standalone editor like Notepad2. Especially for you as “newbie” (as you said) its probably easier to use an IDE like Eclipse or Netbeans.


#42

helga-2.22-415.tar.gz released.


#43

were do I get the download link for it


#44

@david: At the end of the document is a link.


#45
  • *Hi Coolcat,

I’m newbie using this plugin, need your help.

I had try to create a new group with this command :

group create -g friend -t open -s nobody -n friend

but the reply from helga is :

“Only admins have the permissions to do this”.

I used openfire 3.6.4 and installed in localhost.

Could you tell me why this can be happen ?

Thank you for the reply.

Ryan

Finds such as “mathematics” or “computer”.


#46

Hi Ryan,

please check the “Configuration” section in the readme that comes with Helga. Why nobody reads a README?

In short: You have to set the plugin.helga.group.admin property to the name of a group that contains people that shall have admin rights for Helga. You have to create this group manually using the admin console. It would be a security risk to give admin rights to everyone as default setting…so nobody has by default

Make sure your admin group is a “closed” group! Therefore just call

group update -g "NameOfTheAdminGroup" -t closed


#47

Hi Coolcat,

I had successfully create a group.

Thank’s for your help…

May i ask again ?

If we want to know who is the member of the spesific group, which command must we used ?

I have tried command “group list” and “group info”, but i can not get the information.

Best regard,

Ryan


#48

I have tried command “group list” and “group info”, but i can not get the information.
You can list the members using group info -g “Groupname”. However, it depends on the group type and your status if you are allowed to see the member list. For large groups the member list is not available at all. Type help group info for more information.


#49

Hi,

Anyone have success trying Helga bot with openfire 3.7.0. It seems to install fine but the actual bot session never starts.

Any and all help appreciated.

Best

Mark


#50

Hi Mark,

there where some API changes in Openfire 3.7.0, so Helga needs probably some changes. I don’t think I will have time in the near future to do this, if ever. However, since the source code is public you might want to dive into the code yourself. It does probably require only a few small changes.


#51

i have openfire 3.7.1 and helga and work


#52

I have loaded the plugin but it doesn’t work i have openfire 4.0.1


#53

Trying on Op 4.1.6, hope it will work