powered by Jive Software

Help ! OpenFire crashes while configuring!

Hello,

When I confirm the database parameters in the web interface, I get this…

I tried to configure it almost only with default parameters.

It’s openfire-3.6.4-1.i386.rpm under SLES 10SP2

Any help would be greatly appreciated

Denis

HTTP ERROR: 500

INTERNAL_SERVER_ERROR

RequestURI=/setup/setup-profile-settings.jsp

Caused by:

java.lang.NullPointerException
     at org.jivesoftware.openfire.admin.setup.setup_002dprofile_002dsettings_jsp._jspService(setup_002dprofile_002dsettings_jsp.java:80)
     at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
     at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1093)
     at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:118)
     at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:66)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:42)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:146)
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
     at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
     at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
     at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
     at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
     at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
     at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
     at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
     at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
     at org.mortbay.jetty.Server.handle(Server.java:324)
     at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
     at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:843)
     at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)
     at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
     at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
     at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
     at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Hello,

I’m really dispaired, I am the single one where OpenFire bugs ?

If anyone could give me some advice it would be great !

Denis

What database do you select in the setup? And do yo have write permissions on /openfire folder and subfolders?

Hello,

It the same problem wheter I choose internal databse or external (mysql)…

It’s the “Administrator account” step/page which crashes

Denis

And about the rights, everything was installed by the rpm automatically and all rights seems correct.

(Everything was installed with owner / rwx “daemon” and openfire is running under “daemon” user)

Maybe I should add that the first time I tried to install it, I choosed “french” as a language, but now if I choose english it still crash…

And now I found the config file, it’s in :

  • /opt/openfire/conf/openfire.xml

And some of my options are saved it, which proves it’s not a permission problem, at least…

Denis

What is saved in the openfire.xml? Do you have embedded-db folder in your installation folder when you select the internal database? You can try creating such folder manually with that user “daemon”.

Hello,

Without doing anything, that’s what I have :

a) This is my embedded-db folder :

ls -l embedded-db/

-rw-r–r-- 1 daemon daemon 411 Aug 7 00:16 openfire.properties
-rw-r–r-- 1 daemon daemon 9833 Aug 7 00:16 openfire.script

b) And this is my conf/openfire.xml

<?xml version="1.0" encoding="UTF-8"?> 9090 9091 en org.jivesoftware.database.DefaultConnectionProvider com.mysql.jdbc.Driver jdbc:mysql://localhost:3306/openfire openfire ****** select 1 true true 5 25 1.0

Your openfire.xml is missing the last tags true. That’s probably because it never finishes. I see your external mysql settings are here. Try this: stop Openfire and change connectio provider tag to this:

org.jivesoftware.database.EmbeddedConnectionProvider

Then start Openfire and try to select the internal db. Or you can do a fresh install and try the embedded-db for the first time.

Ok I tried but whatever I do on the database step, it seems to work and the config file is saved.

But whatever I do it crashed on “Admin account” with the same error.

Another strange point, even if everything is saved and comes back later, the Server Settings / domain is not saved ?

OK I even tried to uninstall openfire, delete all files, reinstall :

rpm -i openfire-3.6.4-1.i386.rpm

openfire 0:off 1:off 2:off 3:on 4:off 5:on 6:off

etc/init.d/openfire start
Starting openfire:

w3m http://localhost:9090
English

Embedded

Profile Default
BUG !!!

Denis

P.S. This is the error :

HTTP ERROR: 500

INTERNAL_SERVER_ERROR

RequestURI=/setup/setup-profile-settings.jsp

Caused by:

java.lang.NullPointerException
¢ at org.jivesoftware.openfire.admin.setup.setup_002dprofile_002dsettings_jsp._jspSe rvice(setup_002dprofile_002dsettings_jsp.java:80)
¢ at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
¢ at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
¢ at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)
at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)
at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:66)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:42)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:146)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)
at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:324)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:843 )
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Powered by Jetty://

⪠â â Viewing <Error 500 INTERNAL_SERVER_ERROR>

Is maybe openfire-3.6.4-1 bugged ?

Well, it can be a bug, though i havent seen a lot of such reports. You can try a standalone version (tar.gz), Just extract it and run (/openfire/bin/ openfire.sh i think).

This error means that Openfire’s internal web server Jetty is crashing, but i cant say what is causing this. Are there any other web servers on this machine like Apache? Also, then you reinstall, dont run it manually, just try to launch the Admin Console. Maybe it is already running and this is causing the conflict. Well, i’m running out of ideas, so i just tell about all the common problems. Another common problem is that some other app is already using 9090 port. But then you won’t be able to launch Admin Console at all.

This error means that Openfire’s internal web server Jetty is crashing, but i cant say what is causing this.

Oh ok… Isn’t there more details in the trace or in some logs ?

Are there any other web servers on this machine like Apache?

Yes there is already tomcat (I think) - I install IBM Jazz Team Concert (jazz.net)

Also, then you reinstall, dont run it manually, just try to launch the Admin Console. Maybe it is already running and this is causing the conflict.

Could you explain me a little better how to do it ? I mean, how to launch only the admin console ?

Well, i’m running out of ideas, so i just tell about all the common problems.

Another common problem is that some other app is already using 9090 port. But then you won’t be able to launch Admin Console at all.

Yes, exactly, it can’t be it…

I will also try your tgz idea…

Denis

Ok now I tried with the tar.gz version and it’s even worse, I get an error as soon as I open the browser :

HTTP ERROR: 500

Cannot load excludes configuration file from jar

RequestURI=/

Caused by:

java.lang.IllegalStateException: Cannot load excludes configuration file from jar
at com.opensymphony.module.sitemesh.factory.DefaultFactory.loadExcludes(DefaultFac tory.java:192)
at com.opensymphony.module.sitemesh.factory.DefaultFactory.loadConfig(DefaultFacto ry.java:121)
at com.opensymphony.module.sitemesh.factory.DefaultFactory.refresh(DefaultFactory. java:282)
at com.opensymphony.module.sitemesh.factory.DefaultFactory.isPathExcluded(DefaultF actory.java:84)
at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:37)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)
at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:324)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.j ava:829)
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Powered by Jetty://

⪠â â Viewing <Error 500 Cannot load excludes configuration file from jar>

Well, I even think it was an old version runnig because when restarting everything, I have nothing anymore openened on port 9090 ?

In fact I cleaned everything now and restarted the .tar.gz version and I can access the admin web interface, but at the same place I get and error :

HTTP ERROR: 500

INTERNAL_SERVER_ERROR

RequestURI=/setup/setup-profile-settings.jsp

Caused by:

java.lang.NullPointerException
¢ at org.jivesoftware.openfire.admin.setup.setup_002dprofile_002dsettings_jsp._jspSe rvice(setup_002dprofile_002dsettings_jsp.java:80)
¢ at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
¢ at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
¢ at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)
at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:11 8)
at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:52)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:66)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:42)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.admin.PluginFilter.doFilter(PluginFilter.java:70)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:146)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)
at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:324)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:843 )
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

Powered by Jetty://

⪠â â Viewing <Error 500 INTERNAL_SERVER_ERROR>

Finally I found a better solution, in less than one hour everything is working, I installed this :

And it worked immediately… Config was simple too…

Same problem here, installing on Solaris from package. Install goes fine, admin cosole comes up, database configuration is fine, openfire.xml gets written and is valid XML. But when trying “profile settings” with the “default” option, it crashes with a null pointer exception at

org.jivesoftware.openfire.admin.setup.setup_002dprofile_002dsettings_jsp._jspService(setup_002dprofile_002dsettings_jsp.java:80)

knowing what exactly is on that line might help

I’m using PostGres as the database, and according to the logs, setting up the tables worked fine.

So… any ideas?

Hi Daniel,

can you resolve localhost and the server name which you did specify for Openfire?

If may help to make sure that /etc/hosts contains “127.0.0.1 localhost example.com” where example.com matches your xmpp server name.

And if the installation did run fine you must restart Openfire to be able to login.

LG

Yea, the host name is fine. I have since found the solution of the problem, as mentioned in two other threads here in the forum: the config doesn’t work with Firefox. It works with MSIE or Konkqueror (no idea about Opera, etc). Apparently it makes some strong assumptions about what the HTTP request looks like - and fails horribly if it looks any different. Seems pretty broken.